cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralph S Theart (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-6249) Camera fails to return an actual FILE_URI it always returns content://
Date Tue, 18 Mar 2014 05:33:45 GMT

    [ https://issues.apache.org/jira/browse/CB-6249?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13938844#comment-13938844
] 

Ralph S Theart commented on CB-6249:
------------------------------------

Yes if you can look more into it that would be great. using file FileEntry.file() is a bit
of a drag but it does return the mime type will test other phone since in the Android world
with devices anyway there is no real standard it seems ...ive seen 3ggp, 3gp, ogg, avi etc...hopefully
the mime-type returned will be what the file is.

> Camera fails to return an actual FILE_URI it always returns content://
> ----------------------------------------------------------------------
>
>                 Key: CB-6249
>                 URL: https://issues.apache.org/jira/browse/CB-6249
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Android, Plugin Camera, Plugin File
>    Affects Versions: 3.4.0
>         Environment: Current Node Version
>     v0.10.25
> Current Cordova CLI Version
>     3.4.0-0.1.0
> Android
>            Reporter: Ralph S Theart
>              Labels: camera, file
>
> No matter what I do I can not get a url of file:///... all I get is 
> {code}
> content://media/external/images/media/1357
> {code}
> Here is my very simple code....
> {code}
> navigator.camera.getPicture(function(imageURI){
>    console.log('GOT IMAGE: '+imageURI);
>    window.resolveLocalFileSystemURL(imageURI, function(entry){
>       console.log(entry.name + " " +entry.fullPath);
>    }, function(e){
>       console.log('Some error occured: '+e.code);
>    }); 
> }, onPhotoFail, {
>    destinationType: 1, 
>    sourceType: pictureSource,
>    mediaType : Camera.MediaType.ALLMEDIA,
>    encodingType: 0,
>    allowEdit : false,
>    correctOrientation:true,
>    saveToPhotoAlbum: false,
>    quality: 50
> });
> {code}
> I always get content://... for the returned path from camera and even the same thing
when I resolve the url. Can you confirm this bug?



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message