cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan Rahlf (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-5520) Should we add "DEBUG=1" to "Preprocessor Macros"->"Debug" ?
Date Thu, 13 Mar 2014 12:54:10 GMT

    [ https://issues.apache.org/jira/browse/CB-5520?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13933196#comment-13933196
] 

Alan Rahlf commented on CB-5520:
--------------------------------

I'm also running into this issue.  I found that this was broken + fixed in an older version
(https://issues.apache.org/jira/browse/CB-253) as well.

> Should we add "DEBUG=1" to "Preprocessor Macros"->"Debug" ?
> -----------------------------------------------------------
>
>                 Key: CB-5520
>                 URL: https://issues.apache.org/jira/browse/CB-5520
>             Project: Apache Cordova
>          Issue Type: Wish
>          Components: iOS
>    Affects Versions: 3.2.0
>            Reporter: glmnbeyond
>            Priority: Minor
>
> I created a helloCordova project via Cordova CLI, and added some debug info to native
code:
> DLog('This is a debug info');
> But the debug info is never outputted.If I use  ALog, the info can be outputted, so I
think it probably has something to do with the "DEBUG" macro.
> After I added "DEBUG=1" to "Preprocessor Macros", ran the helloCordova target, DLog can
be outputted.
> So here is my question:
> Should we add "DEBUG=1" to iOS template project->"Build Settings"-> "Preprocessor
Macros" ->"Debug" ?



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message