cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jesse MacFadyen (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (CB-4524) .NET Framework version detected incorrectly
Date Wed, 08 Jan 2014 02:14:50 GMT

     [ https://issues.apache.org/jira/browse/CB-4524?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jesse MacFadyen reopened CB-4524:
---------------------------------


> .NET Framework version detected incorrectly
> -------------------------------------------
>
>                 Key: CB-4524
>                 URL: https://issues.apache.org/jira/browse/CB-4524
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: WP7, WP8
>    Affects Versions: 3.0.0
>         Environment: Windows 8, Visual Studio 2012, Windows Phone 8 SDK
> Microsoft (R)-Buildmodul, Version 4.0.30319.17929
> Microsoft .NET Framework, Version 4.0.30319.18051
>            Reporter: Wolfgang Koller
>            Assignee: Jesse MacFadyen
>              Labels: cordova, cordova-cli, framework, net-4.0
>             Fix For: 3.1.0
>
>
> The project fails to create even though I have the latest Windows Phone 8 SDK installed,
including the correct .NET Framework version. This is caused by the invalid regular expression
to check the version number.
> On line 78 of "\.cordova\lib\wp\cordova\3.0.0\wp8\bin\check_reqs.js" there is a check
for "version", however in my installed msbuild command the version is output using an upper
case 'V'. I guess this might be due to the German version of the .NET Framework?!
> Changing the check to be case insensitive would certainly solve the problem, although
other language issues should be considered as well (e.g. if the word "version" is written
differently).



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message