cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Angela Fowler (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CB-5393) Android's Online bridge sometimes doesn't work on KitKat
Date Thu, 12 Dec 2013 22:43:08 GMT

    [ https://issues.apache.org/jira/browse/CB-5393?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13846074#comment-13846074
] 

Angela Fowler edited comment on CB-5393 at 12/12/13 10:42 PM:
--------------------------------------------------------------

Also in Nexus S i.e. no alerts
Correction : Nexus44KitKat in screen shot is a Nexus 7.


was (Author: amfowler):
Also in Nexus S i.e. no alerts

> Android's Online bridge sometimes doesn't work on KitKat
> --------------------------------------------------------
>
>                 Key: CB-5393
>                 URL: https://issues.apache.org/jira/browse/CB-5393
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Android
>    Affects Versions: 2.9.0, 3.0.0
>            Reporter: Andrew Grieve
>            Assignee: Andrew Grieve
>             Fix For: 3.1.0, 2.9.1
>
>         Attachments: framework.zip, mobilespec.zip, screenshot-1.jpg
>
>
> Here's an app /w source that can reproduce the problem consistently. I've made some tweaks
to exacerbate the scenario in which it occurs. I'm fairly certain that happens when online
changes back and forth too fast.
> The bug happens with & without the debugger attached.
> How to use the test app:
> - The bug is happening consistently for me on start-up and causes the page to not load
correctly. If you get an alert saying that it didn't start-up, click the "Refresh Page" button
at the top.
>  - The bug doesn't appear on the second time (at least for me) (no alerts)
> - Click the "Benchmark exec" button and wait for it to report the bridge speed.
>  - Notice that it seems to work fine
> - Now check the "Use two echos at once" box and run the test again a few times
>  - Notice that you get an alert saying that no echo was received after a certain number
of calls.
> The bug will not happen with the pre-KitKat WebView.
> mobilespec.zip & framework.zip have the sources.



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message