cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Georg Howen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-5454) Plugin Mapping Issue
Date Thu, 28 Nov 2013 20:47:35 GMT

    [ https://issues.apache.org/jira/browse/CB-5454?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13835072#comment-13835072
] 

Georg Howen commented on CB-5454:
---------------------------------

I investigated a little further...

The problem is _not_ the config.xml. My current workaround is to remove the ios platform and
then add the ios platform again. This basically rebuild everything and after that everything
worked just fine.

Note: Do save your artwork (icons, splashscreen) before removing the platform - I didn't....

After the complete rebuild I changed the config.xml to the one before the platform rebuild
and things were just fine. So there must be a problem somewhere else when removing and adding
a plugin.

> Plugin Mapping Issue
> --------------------
>
>                 Key: CB-5454
>                 URL: https://issues.apache.org/jira/browse/CB-5454
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CLI, iOS, Plugins
>    Affects Versions: 3.1.0
>         Environment: iOS
>            Reporter: Mike Hartington
>              Labels: cli, config.xml,, cordova, cordova-cli
>
> Once I've removed a plugin, I'm unable to add any plugins back again. So from the command
line,
> cordova plugin rm org.apache.cordova.device
> cordova plugin add org.apache.cordova.device
> Everything installs properly but once I go into Xcode and run the project, my console
puts out 
> 2013-11-20 14:59:28.301 ProductDemo[65497:a0b] CDVPlugin class CDVStatusBar (pluginName:
StatusBar) does not exist.
> 2013-11-20 14:59:28.302 ProductDemo[65497:a0b] ERROR: Plugin 'StatusBar' not found, or
is not a CDVPlugin. Check your plugin mapping in config.xml.
> 2013-11-20 14:59:28.303 ProductDemo[65497:a0b] -[CDVCommandQueue executePending] [Line
117] FAILED pluginJSON = [
>   "INVALID",
>   "StatusBar",
>   "overlaysWebView",
>   [
>     true
>   ]
> ]
> I've run thought the debugging option and no errors come up so I'm not sure what the
issue is,  but my config.xml is correct and everything is copied over as far as files go.
Anyone have this issue too?



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message