cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Ritter (JIRA)" <>
Subject [jira] [Commented] (CB-4971) Installation of plugins does not work for iOS
Date Wed, 09 Oct 2013 03:05:44 GMT


Brian Ritter commented on CB-4971:

I've also having this with other plugins including "org.apache.cordova.device".

This issue pretty much puts any iOS development dead in the water.

Is there a manual workaround for this issue?  I didn't see any documentation on how to manually
install the plugins.  I'd really rather avoid going that route and hope this is fixed ASAP.

> Installation of plugins does not work for iOS
> ---------------------------------------------
>                 Key: CB-4971
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Plugin Contacts, Plugin Device, Plugin Dialogs
>    Affects Versions: 3.0.0, 3.1.0
>         Environment: iOS 
>            Reporter: Oleg
>            Priority: Critical
>              Labels: ios, plugin
>             Fix For: Master, 3.0.0, 3.1.0
>   Original Estimate: 72h
>  Remaining Estimate: 72h
> Installation of iOS plugins does not work for iOS.
> Update: does not work in 3.1 cordova either.
> When installing the plugin via "cordova plugin add", the plugins fail to install correctly
to the iOS platform:
> - source code (.js, .m, .h and .bundle) files are not copied over
> - proper frameworks are not being added to the project
> - config.xml file is not updated with plugin information
> Tried it on Device, Contacts and Dialogs and some other plugins.
> Update: tried on network-information plugin with cordova 3.1
> the workaround is to perform the above steps manually. but it is not documented anywhere.
> Note: it worked for me during one test, when the project was fresh. However after making
a few minor changes and running "cordova prepare" or "cordova build" a few times, it stops
working for iOS - i.e. you cannot add plugins without issues above. Android works fine.

This message was sent by Atlassian JIRA

View raw message