cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Venkata Kiran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-4660) Cordova Android project created using Cordova CLI is not compiling in eclipse.
Date Tue, 10 Sep 2013 09:44:52 GMT

    [ https://issues.apache.org/jira/browse/CB-4660?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13762904#comment-13762904
] 

Venkata Kiran commented on CB-4660:
-----------------------------------

I think the status should be still open. There are 2 parts in the problem reported. While
the 2nd part is intermittent and so it possible that it may be reproduced. But the below errors
are reproducible and I believe they needs to resolved.

error: Error: String types not allowed (at 'configChanges' with value 'orientation|keyboardHidden|keyboard|screenSize|locale').
error: No resource identifier found for attribute 'hardwareAccelerated' in package 'android'
                
> Cordova Android project created using Cordova CLI is not compiling in eclipse.
> ------------------------------------------------------------------------------
>
>                 Key: CB-4660
>                 URL: https://issues.apache.org/jira/browse/CB-4660
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CLI, Docs
>    Affects Versions: 3.0.0
>         Environment: Window 7, eclipse Juno, Android 2.3 - 4.3
>            Reporter: Venkata Kiran
>            Assignee: Braden Shepherdson
>            Priority: Minor
>
> When an Android project is created using cordova command line and then imported into
eclipse, the blank project created is not compiling. 
> The following errors are shown during compilation.
> error: Error: String types not allowed (at 'configChanges' with value 'orientation|keyboardHidden|keyboard|screenSize|locale').
> error: No resource identifier found for attribute 'hardwareAccelerated' in package 'android'
> After changing the project target build to 18 from 10, then these errors are resolved,
but the below errors continue even before changing the API version and also the API version.
> DroidGap cannot be resolved to a type
> Config cannot be resolved
> The import org.apache.cordova cannot be resolved
> The method onCreate(Bundle) of type HelloCordova must override or implement a supertype
method
> The blank project created by cordova should compile without any issues.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message