cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-4073) npm install of cordova-cli regularly fails due to express 3.0.0alpha1
Date Wed, 03 Jul 2013 18:40:20 GMT

    [ https://issues.apache.org/jira/browse/CB-4073?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13699298#comment-13699298
] 

ASF subversion and git services commented on CB-4073:
-----------------------------------------------------

Commit 5f841a8d8d44f90621e6222dd4eabb886193586b in branch refs/heads/master2 from Fil Maj
[ https://git-wip-us.apache.org/repos/asf?p=cordova-cli.git;h=5f841a8 ]

2.9.1. [CB-4073] Qualified express dependency with minor version. [CB-4058] Removed ripple
emulator as dependency until windows issues can be resolved.

                
> npm install of cordova-cli regularly fails due to express 3.0.0alpha1
> ---------------------------------------------------------------------
>
>                 Key: CB-4073
>                 URL: https://issues.apache.org/jira/browse/CB-4073
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CLI
>    Affects Versions: 2.9.0
>         Environment: Mac OS X 10.8.4
> Node v0.10.12
>            Reporter: Matt Gaunt
>            Assignee: Filip Maj
>
> When running sudo npm install -g cordova I get the following error:
> npm ERR! TypeError: Invalid Version: 3.0.0alpha1
> npm ERR!     at new SemVer (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:257:11)
> npm ERR!     at SemVer.compare (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:296:13)
> npm ERR!     at compare (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:410:31)
> npm ERR!     at rcompare (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:420:10)
> npm ERR!     at Array.sort (native)
> npm ERR!     at Function.maxSatisfying (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:838:6)
> npm ERR!     at next (/usr/local/lib/node_modules/npm/lib/cache.js:699:21)
> npm ERR!     at /usr/local/lib/node_modules/npm/lib/cache.js:678:5
> npm ERR!     at saved (/usr/local/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:138:7)
> npm ERR!     at Object.oncomplete (fs.js:107:15)
> npm ERR! If you need help, you may report this log at:
> npm ERR!     <http://github.com/isaacs/npm/issues>
> npm ERR! or email it to:
> npm ERR!     <npm-@googlegroups.com>
> npm ERR! System Darwin 12.4.0
> npm ERR! command "node" "/usr/local/bin/npm" "-g" "install" "generator-cordova"
> npm ERR! cwd /Users/mattgaunt/Programming/Workspace/generator-cordova-matt
> npm ERR! node -v v0.10.12
> npm ERR! npm -v 1.3.1
> Changing the package.json for express from 3.0 to 3.0.0 seems to fix the issue.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message