cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robin North (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CB-4070) Cordova CLI 2.9.0 platform add wp8 broken
Date Wed, 03 Jul 2013 09:54:22 GMT

     [ https://issues.apache.org/jira/browse/CB-4070?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robin North updated CB-4070:
----------------------------

    Description: 
Adding 'wp8' as a platform to a new Cordova 2.9.0 project using the CLI is currently broken.

Steps to reproduce:

- Create a new project using the CLI: cordova -d create test
- Add the Windows Phone 8 platform: cordova -d platform add wp8

{quote}
C:\Users\Robin\Desktop\test>cordova -d platform add wp8
Requesting https://git-wip-us.apache.org/repos/asf?p=cordova-wp8.git;a=snapshot;h=2.9.0;sf=tgz...
Download complete. Extracting...
Checking if platform "wp8" passes minimum requirements...
Checking wp8 requirements...
Running ""C:\Users\Robin\.cordova\lib\wp8\cordova\2.9.0\bin\check_reqs"" (output to follow)
The system cannot find the path specified.
{quote}

The issues appears to be that the wp8_parser.js module is expecting the wp8 repo from https://git-wip-us.apache.org/repos/asf?p=cordova-wp8.git;a=snapshot;h=2.9.0;sf=tgz
to have the same directory structure and contents as it did in 2.8.0, whereas it seems to
have changed with 2.9.0 to bundle both wp7 and wp8 platforms in one repo (ref. https://github.com/apache/cordova-wp8/tree/2.8.x
vs https://github.com/apache/cordova-wp8/tree/2.9.x).

  was:
Adding 'wp8' as a platform to a new Cordova 2.9.0 project using the CLI is currently broken.

Steps to reproduce:

- Create a new project using the CLI: cordova -d create test
- Add the Windows Phone 8 platform: cordova -d platform add wp8

bq. C:\Users\Robin\Desktop\test>cordova -d platform add wp8
Requesting https://git-wip-us.apache.org/repos/asf?p=cordova-wp8.git;a=snapshot;h=2.9.0;sf=tgz...
Download complete. Extracting...
Checking if platform "wp8" passes minimum requirements...
Checking wp8 requirements...
Running ""C:\Users\Robin\.cordova\lib\wp8\cordova\2.9.0\bin\check_reqs"" (output to follow)
The system cannot find the path specified.

The issues appears to be that the wp8_parser.js module is expecting the wp8 repo from https://git-wip-us.apache.org/repos/asf?p=cordova-wp8.git;a=snapshot;h=2.9.0;sf=tgz
to have the same directory structure and contents as it did in 2.8.0, whereas it seems to
have changed with 2.9.0 to bundle both wp7 and wp8 platforms in one repo (ref. https://github.com/apache/cordova-wp8/tree/2.8.x
vs https://github.com/apache/cordova-wp8/tree/2.9.x).

    
> Cordova CLI 2.9.0 platform add wp8 broken
> -----------------------------------------
>
>                 Key: CB-4070
>                 URL: https://issues.apache.org/jira/browse/CB-4070
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CLI
>    Affects Versions: 2.9.0
>         Environment: Windows 8 Pro x64
>            Reporter: Robin North
>            Assignee: Filip Maj
>            Priority: Critical
>
> Adding 'wp8' as a platform to a new Cordova 2.9.0 project using the CLI is currently
broken.
> Steps to reproduce:
> - Create a new project using the CLI: cordova -d create test
> - Add the Windows Phone 8 platform: cordova -d platform add wp8
> {quote}
> C:\Users\Robin\Desktop\test>cordova -d platform add wp8
> Requesting https://git-wip-us.apache.org/repos/asf?p=cordova-wp8.git;a=snapshot;h=2.9.0;sf=tgz...
> Download complete. Extracting...
> Checking if platform "wp8" passes minimum requirements...
> Checking wp8 requirements...
> Running ""C:\Users\Robin\.cordova\lib\wp8\cordova\2.9.0\bin\check_reqs"" (output to follow)
> The system cannot find the path specified.
> {quote}
> The issues appears to be that the wp8_parser.js module is expecting the wp8 repo from
https://git-wip-us.apache.org/repos/asf?p=cordova-wp8.git;a=snapshot;h=2.9.0;sf=tgz to have
the same directory structure and contents as it did in 2.8.0, whereas it seems to have changed
with 2.9.0 to bundle both wp7 and wp8 platforms in one repo (ref. https://github.com/apache/cordova-wp8/tree/2.8.x
vs https://github.com/apache/cordova-wp8/tree/2.9.x).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message