cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Petr Klus (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-4023) Can't install version 2.9.0 of cli
Date Thu, 27 Jun 2013 14:44:20 GMT

    [ https://issues.apache.org/jira/browse/CB-4023?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13694763#comment-13694763
] 

Petr Klus commented on CB-4023:
-------------------------------

Same here:
npm http 304 https://registry.npmjs.org/express
npm ERR! TypeError: Invalid Version: 3.0.0alpha1
npm ERR!     at new SemVer (/opt/local/lib/node_modules/npm/node_modules/semver/semver.js:257:11)
npm ERR!     at SemVer.compare (/opt/local/lib/node_modules/npm/node_modules/semver/semver.js:296:13)
npm ERR!     at compare (/opt/local/lib/node_modules/npm/node_modules/semver/semver.js:410:31)
npm ERR!     at rcompare (/opt/local/lib/node_modules/npm/node_modules/semver/semver.js:420:10)
npm ERR!     at Array.sort (native)
npm ERR!     at Function.maxSatisfying (/opt/local/lib/node_modules/npm/node_modules/semver/semver.js:838:6)
npm ERR!     at next (/opt/local/lib/node_modules/npm/lib/cache.js:699:21)
npm ERR!     at /opt/local/lib/node_modules/npm/lib/cache.js:678:5
npm ERR!     at saved (/opt/local/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:138:7)
npm ERR!     at Object.oncomplete (fs.js:107:15)
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>


And versions:
CUNE:phonegap-testing-android petr$ npm -v
1.3.1
CUNE:phonegap-testing-android petr$ node -v
v0.10.12

Running on mac, node and npm obtained using macports
                
> Can't install version 2.9.0 of cli
> ----------------------------------
>
>                 Key: CB-4023
>                 URL: https://issues.apache.org/jira/browse/CB-4023
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CLI
>    Affects Versions: 2.0.0
>         Environment: npm 1.3.3, node 0.10.10
>            Reporter: Dan Moore
>            Assignee: Filip Maj
>
> I ran 
> npm remove -g cordova
> npm install -g cordova
> And I get this error message:
> ...
> npm http 304 https://registry.npmjs.org/express
> npm http GET https://registry.npmjs.org/elementtree/-/elementtree-0.1.3.tgz
> npm http GET https://registry.npmjs.org/colors/-/colors-0.6.0.tgz
> npm ERR! TypeError: Invalid Version: 3.0.0alpha1
> npm ERR!     at new SemVer (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:257:11)
> npm ERR!     at SemVer.compare (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:296:13)
> npm ERR!     at compare (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:410:31)
> npm ERR!     at rcompare (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:420:10)
> npm ERR!     at Array.sort (native)
> npm ERR!     at Function.maxSatisfying (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:838:6)
> npm ERR!     at next (/usr/local/lib/node_modules/npm/lib/cache.js:699:21)
> npm ERR!     at /usr/local/lib/node_modules/npm/lib/cache.js:678:5
> npm ERR!     at saved (/usr/local/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:138:7)
> npm ERR!     at Object.oncomplete (fs.js:107:15)
> npm ERR! If you need help, you may report this log at:
> npm ERR!     <http://github.com/isaacs/npm/issues>
> npm ERR! or email it to:
> npm ERR!     <npm-@googlegroups.com>
> npm ERR! System Linux 2.6.32-358.6.2.el6.x86_64
> npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "cordova"
> npm ERR! cwd /home/mooreds
> npm ERR! node -v v0.10.10
> npm ERR! npm -v 1.3.1
> npm http GET https://registry.npmjs.org/plist/-/plist-0.4.3.tgz
> ...
> Looking in npm-debug.log, I see:
> 593 silly lockFile 83d909f9-glob-3-2-1 glob@3.2.1
> 594 verbose lock glob@3.2.1 /home/mooreds/.npm/83d909f9-glob-3-2-1.lock
> 595 silly addNameRange number 2 { name: 'express', range: '>=3.0.0-0 <3.1.0-0',
hasData: true }
> 596 silly addNameRange versions [ 'express',
> 596 silly addNameRange   [ '0.14.0',
> 596 silly addNameRange     '0.14.1',
> 596 silly addNameRange     '1.0.0beta',
> 596 silly addNameRange     '1.0.0beta2',
> 596 silly addNameRange     '1.0.0rc',
> 596 silly addNameRange     '1.0.0rc2',
> 596 silly addNameRange     '1.0.0rc3',
> 596 silly addNameRange     '1.0.0rc4',
> 596 silly addNameRange     '1.0.0',
> 596 silly addNameRange     '1.0.1',
> 596 silly addNameRange     '1.0.2',
> 596 silly addNameRange     '1.0.3',
> 596 silly addNameRange     '1.0.4',
> 596 silly addNameRange     '1.0.5',
> 596 silly addNameRange     '1.0.6',
> 596 silly addNameRange     '1.0.7',
> 596 silly addNameRange     '2.0.0beta',
> 596 silly addNameRange     '1.0.8',
> 596 silly addNameRange     '2.0.0beta2',
> 596 silly addNameRange     '2.0.0beta3',
> 596 silly addNameRange     '2.0.0rc',
> 596 silly addNameRange     '2.0.0rc2',
> 596 silly addNameRange     '2.0.0rc3',
> 596 silly addNameRange     '2.0.0',
> 596 silly addNameRange     '2.1.0',
> 596 silly addNameRange     '2.1.1',
> 596 silly addNameRange     '2.2.0',
> 596 silly addNameRange     '2.2.1',
> 596 silly addNameRange     '2.2.2',
> 596 silly addNameRange     '2.3.0',
> 596 silly addNameRange     '2.3.1',
> 596 silly addNameRange     '2.3.2',
> 596 silly addNameRange     '2.3.3',
> 596 silly addNameRange     '2.3.4',
> 596 silly addNameRange     '2.3.5',
> 596 silly addNameRange     '2.3.6',
> 596 silly addNameRange     '2.3.7',
> 596 silly addNameRange     '2.3.8',
> 596 silly addNameRange     '2.3.9',
> 596 silly addNameRange     '2.3.10',
> 596 silly addNameRange     '2.3.11',
> 596 silly addNameRange     '2.3.12',
> 596 silly addNameRange     '2.4.0',
> 596 silly addNameRange     '2.4.1',
> 596 silly addNameRange     '2.4.2',
> 596 silly addNameRange     '2.4.3',
> 596 silly addNameRange     '2.4.4',
> 596 silly addNameRange     '2.4.5',
> 596 silly addNameRange     '2.4.6',
> 596 silly addNameRange     '2.4.7',
> 596 silly addNameRange     '2.5.0',
> 596 silly addNameRange     '2.5.1',
> 596 silly addNameRange     '2.5.2',
> 596 silly addNameRange     '2.5.3',
> 596 silly addNameRange     '2.5.4',
> 596 silly addNameRange     '2.5.5',
> 596 silly addNameRange     '2.5.6',
> 596 silly addNameRange     '2.5.7',
> 596 silly addNameRange     '2.5.8',
> 596 silly addNameRange     '2.5.9',
> 596 silly addNameRange     '3.0.0alpha1',
> 596 silly addNameRange     '3.0.0alpha2',
> 596 silly addNameRange     '3.0.0alpha3',
> 596 silly addNameRange     '3.0.0alpha4',
> 596 silly addNameRange     '3.0.0alpha5',
> 596 silly addNameRange     '3.0.0beta1',
> 596 silly addNameRange     '3.0.0beta2',
> 596 silly addNameRange     '3.0.0beta3',
> 596 silly addNameRange     '2.5.10',
> 596 silly addNameRange     '3.0.0beta4',
> 596 silly addNameRange     '2.5.11',
> 596 silly addNameRange     '3.0.0beta6',
> 596 silly addNameRange     '3.0.0beta7',
> 596 silly addNameRange     '3.0.0rc1',
> 596 silly addNameRange     '3.0.0rc2',
> 596 silly addNameRange     '3.0.0rc3',
> 596 silly addNameRange     '3.0.0rc4',
> 596 silly addNameRange     '3.0.0rc5',
> 596 silly addNameRange     '3.0.0',
> 596 silly addNameRange     '3.0.1',
> 596 silly addNameRange     '3.0.2',
> 596 silly addNameRange     '3.0.3',
> 596 silly addNameRange     '3.0.4',
> 596 silly addNameRange     '3.0.5',
> 596 silly addNameRange     '3.0.6',
> 596 silly addNameRange     '3.1.0',
> 596 silly addNameRange     '3.1.1',
> 596 silly addNameRange     '3.1.2',
> 596 silly addNameRange     '3.2.0',
> 596 silly addNameRange     '3.2.1',
> 596 silly addNameRange     '3.2.2',
> 596 silly addNameRange     '3.2.3',
> 596 silly addNameRange     '3.2.4',
> 596 silly addNameRange     '3.2.5',
> 596 silly addNameRange     '3.2.6',
> 596 silly addNameRange     '3.3.0' ] ]
> 597 error TypeError: Invalid Version: 3.0.0alpha1
> 597 error     at new SemVer (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:257:11)
> 597 error     at SemVer.compare (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:296:13)
> 597 error     at compare (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:410:31)
> 597 error     at rcompare (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:420:10)
> 597 error     at Array.sort (native)
> 597 error     at Function.maxSatisfying (/usr/local/lib/node_modules/npm/node_modules/semver/semver.js:838:6)
> 597 error     at next (/usr/local/lib/node_modules/npm/lib/cache.js:699:21)
> 597 error     at /usr/local/lib/node_modules/npm/lib/cache.js:678:5
> 597 error     at saved (/usr/local/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:138:7)
> 597 error     at Object.oncomplete (fs.js:107:15)
> 598 error If you need help, you may report this log at:
> 598 error     <http://github.com/isaacs/npm/issues>
> 598 error or email it to:
> 598 error     <npm-@googlegroups.com>
> 599 error System Linux 2.6.32-358.6.2.el6.x86_64
> 600 error command "node" "/usr/local/bin/npm" "install" "-g" "cordova"
> 601 error cwd /home/mooreds
> 602 error node -v v0.10.10
> 603 error npm -v 1.3.1
> 604 verbose exit [ 1, true ]
> So it appears to be some issue with express?  (I'm new to node.) 
> I tried to install express@3.0.0 independently, but still get this error message.
> If this isn't the appropriate place for this message, let me know what is and I'll gladly
post there.
> Thanks.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message