cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Filip Maj (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (CB-3497) ./bin/create script requires `npm install` to be run
Date Tue, 04 Jun 2013 20:19:19 GMT

     [ https://issues.apache.org/jira/browse/CB-3497?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Filip Maj reopened CB-3497:
---------------------------


Now I get a problem where after running bbndk-env.sh, the appropriate variables are not exported
:(. Here's my terminal output:

{code}
fil-MacBookAir:tb fil$ sh ../../SDKs/bb10ndk/bbndk-env.sh
fil-MacBookAir:tb fil$ echo $PATH
/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/Users/fil/SDKs/android-sdk-macosx/tools:/Users/fil/SDKs/android-sdk-macosx/platform-tools:/Users/fil/src/joDoc:/Users/fil/src/mobify-js-tools/bin
fil-MacBookAir:tb fil$ ./cordova/run
[WARN]    No signing password provided, will omit debug token generation
[BUILD]   Populating application source
[BUILD]   Parsing config.xml
[BUILD]   Generating output files
[WARN]    Failed to find debug token
[ERROR]   BBNDK tools could not be found. Please ensure you have installed the BlackBerry
Native SDK [http://developer.blackberry.com/native/] and have the PATH configured via bbndk-env
script.
{code}

Similarly to running npm install, is there a way we can bootstrap running the env.sh script
automatically when running ./bin/create ? Alternatively, as in Android's implementation, we
require that the android command line tools are properly added to the path. We can enforce
a similar constraint for blackberry.
                
> ./bin/create script requires `npm install` to be run
> ----------------------------------------------------
>
>                 Key: CB-3497
>                 URL: https://issues.apache.org/jira/browse/CB-3497
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: BlackBerry
>    Affects Versions: 2.8.0
>            Reporter: Filip Maj
>            Assignee: Bryan Higgins
>             Fix For: 2.8.0
>
>
> Tsted with latest 2.8.x branch.
> The create script should bootstrap itself as appropriate. Right now, you need to run
npm install before you can run create.
> This is an issue for tools consuming the script (i.e. cordova-cli).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message