cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CB-3504) Cordova 2.7.0 uses WebResourceResponse which is only avalable in API Level 11
Date Fri, 24 May 2013 17:22:24 GMT
Andrew created CB-3504:
--------------------------

             Summary: Cordova 2.7.0 uses WebResourceResponse which is only avalable in API
Level 11
                 Key: CB-3504
                 URL: https://issues.apache.org/jira/browse/CB-3504
             Project: Apache Cordova
          Issue Type: Bug
          Components: Android
    Affects Versions: 2.7.0
            Reporter: Andrew
            Assignee: Joe Bowser
            Priority: Critical


In CordovaWebViewClient.java, android.webkit.WebResourceResponse is imported and used by the
methods shouldInterceptRequest and getWhitelistResponse.  But since android.webkit.WebResourceResponse
is only available on devices >= API Level 11, this causes cordova apps to crash on devices
at a lower API Level like my Samsung Galaxy S.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message