cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven Gill <stevengil...@gmail.com>
Subject Re: [DISCUSS] cordova@8 & tools release
Date Fri, 15 Dec 2017 18:24:28 GMT
Just a heads up. One test is failing in cordova-lib for node 8. The fix was
landed in cordova-fetch (which is also being voted on)

On Wed, Dec 13, 2017 at 9:08 PM, Darryl Pogue <dvpdiner2@gmail.com> wrote:

> Given the number of times I've run into (and complained about) build
> failures due to unexpected npm version bugs, I'm 100% in favour of
> this.
>
>
> On Wed, Dec 13, 2017 at 6:15 PM, Terence M. Bandoian <terence@tmbsw.com>
> wrote:
> > Does removing '--no-fetch' apply to adding plugins?  I've recently had to
> > use that option to get local plugins (file spec) added without hanging.
>
> If there are cases where cordova-fetch is failing to install plugins,
> please file bugs so we can know what they are.
>
>
> On Wed, Dec 13, 2017 at 8:14 PM, Rabindra Nayak
> <rabindra.mobile@gmail.com> wrote:
> >
> > What could be functionalities  of new tool ? Any high level design in
> mind
> > ,If we are dropping  npm then where those templates will  come.
> >
> > Moreover tools like visual studio  17 Microsoft team has integrated
> Cordova
> > framework ,like that if we integrate cordova  tool in Android studio and
> > Xcode it could be useful ,again you people can see how far it is
> possible .
>
> This will not affect how end users install or use Cordova, nor should
> it affect tools like VS that integrate with Cordova.
>
> Currently cordova-lib has a package dependency on an old and
> unsupported version of npm (2.x). That means when you install Cordova
> using npm, it actually installs a second older copy of npm internally.
> That has caused problems for people (including myself) due to commands
> around Cordova sometimes using the system npm and sometimes using the
> older npm, and there are behaviour differences between the two
> versions.
>
> The proposal is for Cordova to stop depending on (and therefore stop
> installing) an older version of npm, and to rely on the system npm and
> the new cordova-fetch system.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
> For additional commands, e-mail: dev-help@cordova.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message