cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Hartington <mikeharting...@gmail.com>
Subject Re: [DISCUSS] Cordova iOS 4.5.1 release
Date Fri, 15 Sep 2017 23:54:23 GMT
Regarding the Viewport and iPhoneX notch, I sent this earlier today.

https://github.com/apache/cordova-plugin-statusbar/pull/85 <https://github.com/apache/cordova-plugin-statusbar/pull/85>


> On Sep 15, 2017, at 7:36 PM, Shazron <shazron@gmail.com> wrote:
> 
> We need a 4.5.1 release soon to address iOS 11 issues.
> 
> Here’s the things that are pending or have been fixed:
> 
> - cordova-ios@4.5.0 has been released which fixes a bunch of things. Now of
> course, we need to have a cordova-ios@4.5.1 release because of the other
> points below…
> 
> - ios-sim is broken, it doesn’t list the new 2017 iPhones. Apple released
> Xcode 9 with a buggy listing of devices using `xcrun simctl` (i.e. listing
> iPhone 8 as iPhone2017-A for example) so we can’t list them properly. I
> have fixed this with a workaround:
> https://github.com/phonegap/ios-sim/issues/218 and
> https://github.com/phonegap/ios-sim/issues/219 - This new ios-sim when
> released needs to go in a new cordova-ios release asap
> 
> - simctl is broken, it doesn’t launch the Simulator (so `cordova emulate
> ios` is affected). I have filed issues:
> https://github.com/phonegap/ios-sim/issues/209 and
> https://github.com/phonegap/simctl/issues/14 . Of course I will have to
> work on those, and no surprise Apple changed things again… This will go in
> the new ios-sim which in turn will go in the new cordova-ios
> 
> - Viewport and iPhone X notch issues – with the help of the community. Need
> to be addressed properly (blog post only?). Summarized by Darryl Pogue:
>    - status bar plugin -- Has a PR to use the safeArea height instead of
> 20px
>    - iPhone X letterboxing -- Requires the use of LaunchStoryboards, not
> really a "bug"
>    - viewport-fit stuff -- Up to the HTML author, not really a "bug", and
> a few blogs posts about it
> 
> - ios-deploy couldn’t compile under Xcode 9. Apple either prevents or had a
> bug where it couldn’t link to Private Frameworks. Workaround added:
> https://github.com/phonegap/ios-deploy/issues/308 . This should have been
> in 4.5.0 already


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message