cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From matrosov-nikita <...@git.apache.org>
Subject [GitHub] cordova-lib pull request #559: Display deprecation message when installing a...
Date Wed, 17 May 2017 12:53:37 GMT
GitHub user matrosov-nikita opened a pull request:

    https://github.com/apache/cordova-lib/pull/559

    Display deprecation message when installing a platform with version lower than api compatible

    <!--
    Please make sure the checklist boxes are all checked before submitting the PR. The checklist
    is intended as a quick reference, for complete details please see our Contributor Guidelines:
    
    http://cordova.apache.org/contribute/contribute_guidelines.html
    
    Thanks!
    -->
    
    ### Platforms affected
    all
    
    ### What does this PR do?
    Repro steps: 
    cordova platform add windows@4.1.0
    
    Actual behavior:
    Get non-informative error message: 'Error: Your windows platform does not have Api.js'
    
    Expected behavior:
    'Using this version of Cordova with older version of cordova-windows is deprecated. Upgrade
to cordova-windows@4.3.0 or newer.
    Error: Your windows platform does not have Api.js'
    
    ### Checklist
    - [ ] [Reported an issue](http://cordova.apache.org/contribute/issues.html) in the JIRA
database
    - [ ] Commit message follows the format: "CB-3232: (android) Fix bug with resolving file
paths", where CB-xxxx is the JIRA ID & "android" is the platform affected.
    - [ ] Added automated test coverage as appropriate for this change.


You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/matrosov-nikita/cordova-lib display-api-compatible-deprecation-message

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/cordova-lib/pull/559.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #559
    
----
commit 444fc4d00edd8ff00712b4158521a2161c0f731c
Author: Nikita Matrosov <v-nimatr@microsoft.com>
Date:   2017-05-17T12:49:56Z

    Display deprecation message when installing a platform with version lower than api compatible

----


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org


Mime
View raw message