cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Maj <maj....@gmail.com>
Subject Re: Platform Version support/coverage
Date Thu, 05 Jan 2017 23:18:45 GMT
Thanks Shaz. If we want to make that happen, then I think that Alex
will need to tweak our cloudapp jenkins instance to run the ios tests
against both iOS 9.3 and 10. Shouldn't be too difficult, as Alex
already has the dual-OS-version setup in place for Android (which is
how we test both 4.4 and 5.1 currently).

What say you, Alex?

On Thu, Jan 5, 2017 at 2:58 PM, Shazron <shazron@gmail.com> wrote:
> For iOS, we usually test on the current iOS version and the one previous,
> so that would be iOS 10 and iOS 9. It follows what cordova-ios currently
> supports, which with cordova-ios@4.4.0 we would increase the minimum
> deployment target to iOS 9 (previously discussed in a thread in this list).
>
> On Thu, Jan 5, 2017 at 1:01 PM, Filip Maj <maj.fil@gmail.com> wrote:
>
>> Hi!
>>
>> TL;DR: what OS versions should we be running our tests on? What
>> versions should we be testing against in our CI?
>>
>> Recently, I received an email from Sauce Labs, letting me know that
>> support for test runs on Android 4.3 and below has officially ended.
>> This reminded me that our current Android CI in cloudapp (which uses
>> Sauce Labs) tests against Android 4.4 and 5.1, so we are starting to
>> cut it pretty close with which versions of Android we are testing
>> against.
>>
>> In general, I wanted to start a discussion around what OS versions of
>> our platforms we intend to support, and which ones we would want CI
>> coverage on?
>>
>> I think we probably want to have some test coverage on newer versions
>> of Android than 5.1. Unfortunately, at this time Sauce Labs does not
>> have support for Android 6 (let alone 7!), so our hands are tied there
>> until Sauce catches up a bit.
>>
>> On iOS, cloudapp currently tests against iOS 9.3. Sauce Labs _does_
>> have support for iOS 10, though, so we could update our CI to get that
>> coverage if we wanted.
>>
>> Our CI also includes coverage for "Windows 10 Store", which, based on
>> some CI output [1], runs on the following environment:
>>
>> Windows OS: installed Windows 10
>> MSBuild Tools: installed 12.0
>> Visual Studio: installed 14.0
>> Windows SDK: installed 8.1
>> Windows Phone SDK: installed 8.1
>>
>> What do y'all think?
>>
>> [1] http://cordova-ci.cloudapp.net:8080/view/Pull%20requests/
>> job/cordova-plugin-camera-pr/115/PLATFORM=windows-10-store/console
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
>> For additional commands, e-mail: dev-help@cordova.apache.org
>>
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org


Mime
View raw message