cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Sorokin (Akvelon)" <v-als...@microsoft.com>
Subject RE: [NODE] Can we drop node 0.x support?
Date Wed, 02 Nov 2016 09:32:53 GMT
Hey guys,

Where are we with dropping node 0.x support? Can we start removing Travis and AppVeryor configs
for it and using the features Node 4+ provides?

Thanks,
Alexander Sorokin

-----Original Message-----
From: Shazron [mailto:shazron@gmail.com] 
Sent: Monday, August 15, 2016 11:59 AM
To: dev@cordova.apache.org
Subject: Re: [NODE] Can we drop node 0.x support?

Also node.js 6.3.0 now supports the --inspect option, which means we can debug cordova using
Chrome Dev Tools:
https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fmobile.twitter.com%2fnodejs%2fstatus%2f763782055788445696&data=01%7c01%7cv-alsoro%40microsoft.com%7c747bf3b25ba64dc7003908d3c4ea885d%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=yl2QTEK2DRe6RXoz2lRvAmYAayW1OdUMlrM08MGJIm0%3d
(although the flag is deemed "experimental")

On Mon, Aug 15, 2016 at 1:30 AM, Shazron <shazron@gmail.com> wrote:

> Sorry, I meant to say Node 7 will be "current" in Oct 2016, this year 
> -- not 2017.
>
> On Mon, Aug 15, 2016 at 1:29 AM, Shazron <shazron@gmail.com> wrote:
>
>> Our docs just specify "Download and install Node.js" which points to 
>> the LTS version 4.4.7 at 
>> https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fnode
>> js.org%2fen%2fdownload%2f&data=01%7c01%7cv-alsoro%40microsoft.com%7c747bf3b25ba64dc7003908d3c4ea885d%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=Lx3NlDxS7UdkDCBhmAvZkyFReTj3rzT71I2qK45QiP0%3d
. If we want to support Node 6 (current version as of this email), we need to point that to
https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fnodejs.org%2fen%2fdownload%2fcurrent%2f&data=01%7c01%7cv-alsoro%40microsoft.com%7c747bf3b25ba64dc7003908d3c4ea885d%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=cvrZc1crnrCyTa6IP4ODA5NKzjl4ky5Pmb%2bG6Gnicw8%3d
instead.
>>
>> Since our code all works on Node 6 already, I would say we should 
>> jump to version 6 as a requirement, and update the docs to point to 
>> Node 6. Node 4 LTS ends 2018-04-01 while Node 6 LTS starts this Oct 
>> 2016 and ends 2019-04-01. Since Node 6 will LTS pretty soon, we 
>> should just jump to that straight away.
>>
>> Consequently Node 7 will be "current" in Oct 2017. One of the 
>> significant things about Node 7 is, according to 
>> https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fnode.
>> green%2f&data=01%7c01%7cv-alsoro%40microsoft.com%7c747bf3b25ba64dc700
>> 3908d3c4ea885d%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=r91acKoSh
>> 6MGQdMZwkgiGyHv2bEqxcGVeodfAkHtCzQ%3d, 99% ES6
>> (ES2015) support and 100% ES7 (ES2016) support.
>>
>> I can setup the JIRA issues to update all our Travis and Appveyor 
>> versions required.
>>
>>
>>
>> On Sun, Aug 14, 2016 at 11:41 PM, Vladimir Kotikov (Akvelon) < 
>> v-vlkoti@microsoft.com> wrote:
>>
>>> There should not be any problems AFAIK.
>>> Last problems have been resolved in cordova@6.2.0 (
>>> https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fcord
>>> ova.apache.org%2fnews%2f2016%2f05%2f24%2ftools-release.html&data=01%
>>> 7c01%7cv-alsoro%40microsoft.com%7c747bf3b25ba64dc7003908d3c4ea885d%7
>>> c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=yYvNrFxxoIc9KDpKTrcj1r09
>>> 3PPZqGWh4mM0%2fxuJY4g%3d)
>>>
>>> -
>>> Best regards, Vladimir
>>>
>>>
>>> -----Original Message-----
>>> From: Victor Sosa [mailto:sosah.victor@gmail.com]
>>> Sent: Sunday, August 14, 2016 8:41 PM
>>> To: dev@cordova.apache.org
>>> Subject: Re: [NODE] Can we drop node 0.x support?
>>>
>>> +1
>>> Also, I've been away from Cordova lately. Does already support v6.x? 
>>> As far as I recall there were problems with it.
>>>
>>> On Sun, Aug 14, 2016, 12:40 AM Steven Gill <stevengill97@gmail.com>
>>> wrote:
>>>
>>> > Yay!
>>> >
>>> > On Aug 12, 2016 9:57 PM, "Simon MacDonald" 
>>> > <simon.macdonald@gmail.com>
>>> > wrote:
>>> >
>>> > > +1
>>> > >
>>> > >
>>> > > Simon Mac Donald
>>> > > https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2f
>>> > > hi.i
>>> > > m%2fsimonmacdonald&data=01%7c01%7cv-vlkoti%40microsoft.com%7c233
>>> > > e798 
>>> > > 4d03f4caf0d8f08d3c46a3753%7c72f988bf86f141af91ab2d7cd011db47%7c1
>>> > > &sda ta=XC6xDMaKyUdqWxzRd8s6uBdSO5Mtr0r7MdhOuU%2f1dFw%3d
>>> > >
>>> > > On Fri, Aug 12, 2016 at 10:26 PM, Kerri Shotts 
>>> > > <kerrishotts@gmail.com>
>>> > > wrote:
>>> > >
>>> > > > +1 as well
>>> > > > Kerri
>>> > > >
>>> > > >
>>> > > >
>>> > > > On Fri, Aug 12, 2016 at 8:18 PM -0500, "Jesse" <
>>> > purplecabbage@gmail.com>
>>> > > > wrote:
>>> > > >
>>> > > >
>>> > > >
>>> > > >
>>> > > >
>>> > > >
>>> > > >
>>> > > >
>>> > > >
>>> > > >
>>> > > > +1
>>> > > > Please!
>>> > > >
>>> > > > > On Aug 12, 2016, at 5:43 PM, Shazron  wrote:
>>> > > > >
>>> > > > > cordova-lib engine says we still do support 0.x:
>>> > > > > https://github.com/apache/cordova-lib/blob/
>>> > > > 2a178662acfad9c779114fddd815e484fc1b6f1d/cordova-lib/package.j
>>> > > > son#
>>> > > > L16
>>> > > > >
>>> > > > > Can we drop support? Seems time.
>>> > > > >
>>> > > > > See:
>>> > > > > https://na01.safelinks.protection.outlook.com/?url=https%3a%
>>> > > > > 2f%2
>>> > > > > ftwitter.com%2ffeross%2fstatus%2f763548182416494593&data=01%
>>> > > > > 7c01
>>> > > > > %7cv-vlkoti%40microsoft.com%7c233e7984d03f4caf0d8f08d3c46a37
>>> > > > > 53%7 
>>> > > > > c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=RuI%2boMCvpI9sXc
>>> > > > > 10Kp ZpIMkjofsOD9lyDcM5PKqwoJA%3d "Node v0.10 will be 
>>> > > > > completely UNSUPPORTED in just 50 days. No
>>> > security
>>> > > > > fixes."
>>> > > >
>>> > > >
>>> > > >
>>> > > >
>>> > > >
>>> > > >
>>> > >
>>> >
>>>
>>> --------------------------------------------------------------------
>>> - To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
>>> For additional commands, e-mail: dev-help@cordova.apache.org
>>>
>>
>>
>
Mime
View raw message