cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cjpearson <...@git.apache.org>
Subject [GitHub] cordova-ios issue #277: CB-11243: Fix target-device and deployment-target pr...
Date Mon, 14 Nov 2016 21:36:06 GMT
Github user cjpearson commented on the issue:

    https://github.com/apache/cordova-ios/pull/277
  
    It seems like the xcconfig settings override the buildFlag flag. When I run this command
on a starter cordova-ios 4.3.0 project, the MinimumOSVersion in the App's Info.plist is still
iOS 8.0.
    
        cordova compile ios --buildFlag="IPHONEOS_DEPLOYMENT_TARGET=9.0"
    
    I get a similar result with the `TARGETED_DEVICE_FAMILY` setting.
    
    I added the settings back into the pbxproj to handle the case where the user doesn't use
one of these config options. Otherwise the default would be a minimum version of iOS 10 and
iPhone only.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org


Mime
View raw message