cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kerri Shotts <kerrisho...@gmail.com>
Subject CB-9762 iOS Launch Storyboard update
Date Sat, 10 Sep 2016 22:31:22 GMT
So, in playing around with my PR, I've discovered the following:

- Travis CI fails because it is using Xcode 6.1; they pass if I specify Xcode 7.3 explicitly.
- Xcode 6.1 does not like the additions I made to the asset library and it complains loudly
about about the storyboard (even when not set as the launch storyboard)
- Cordova documentation (http://cordova.apache.org/docs/en/latest/guide/platforms/ios/index.html#requirements-and-support)
indicates that the minimum required version of Xcode is 6.0
- Xcode 6.0 will run on macOS 10.9 and higher.

This leads me to believe that this would be considered a breaking change, since the minimum
version of Xcode would now be 7.0. Xcode 7.0 requires a minimum of macOS 10.10.4. 

Given all of that, I'm thinking this can't be rolled out until we have a major cordova-ios
release. Thoughts? 

[Also added the above to the JIRA issue]

~Kerri
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org


Mime
View raw message