cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexis Kofman <alexis.kof...@gmail.com>
Subject Re: Cannot add/find cordova-ios 4.1.0
Date Thu, 03 Mar 2016 18:25:00 GMT
Yep I meant android@5.1.1, sorry for the mistake.
Deleting the cache ~/.cordova/lib/npm_cache works for me ! Thx.

On Thu, Mar 3, 2016 at 6:57 PM, Carlos Santana <csantana23@gmail.com> wrote:

> Like I said it depends of the cache timeout
>
> I also used latest and I got 4.0.1 not 4.1.0, because the .cache.json
> lastest=4.0.1 and already had it in downloaded in the cache.
>
>
> On Thu, Mar 3, 2016 at 12:44 PM julio cesar sanchez <
> jcesarmobile@gmail.com>
> wrote:
>
> > I got 4.1.0 using @latest
> >
> > 2016-03-03 18:22 GMT+01:00 Carlos Santana <csantana23@gmail.com>:
> >
> > > Filed a bug [1]
> > >
> > > Take into account that in future we will be using external npm in
> Cordova
> > > CLI, and not have our own copy of the npm cache.
> > >
> > > https://issues.apache.org/jira/browse/CB-10770
> > >
> > >
> > > I guess for now we can wait 24 hours, before tweeting/blog until bug is
> > > fix.
> > >
> > >
> > >
> > > On Thu, Mar 3, 2016 at 12:06 PM Carlos Santana <csantana23@gmail.com>
> > > wrote:
> > >
> > > > I took a quick look, I have a guess on what's going on
> > > >
> > > > People should just wait 24 hours and try again, or use platform add
> by
> > > > path or git
> > > > Or delete the cache ~/.cordova/lib/npm_cache
> > > >
> > > > We configure the npm cache config [1] with cache-min = 3600 *24,
> > meaning
> > > > 24 hours
> > > > if .cache.json [2] is not older than 24 hours npm will not try the
> > > network
> > > >
> > > > Also I think there is bug since there is no catch/fail when calling
> npm
> > > > cache add
> > > >
> > > > [1]:
> > > >
> > >
> >
> https://github.com/apache/cordova-lib/blob/master/cordova-lib/src/cordova/lazy_load.js#L153
> > > > [2]: ~/.cordova/lib/npm_cache/
> > registry.npmjs.org/cordova-ios/.cache.json
> > > > [3]:
> > > >
> > >
> >
> https://github.com/apache/cordova-lib/blob/master/cordova-lib/src/cordova/lazy_load.js#L158
> > > >
> > > >
> > > > On Thu, Mar 3, 2016 at 11:32 AM So, Byoungro <byoungro.so@intel.com>
> > > > wrote:
> > > >
> > > >> Alexis,
> > > >> ios@5.1.1 does not exist.
> > > >> You can find the available versions here.
> > > >> https://github.com/apache/cordova-ios/releases
> > > >> If you need the latest Android version, do the following:
> > > >> cordova platform add android@5.1.1
> > > >>
> > > >> Zarko,
> > > >> I have no issue with adding ios@4.1.0.
> > > >> You may want to check your connection and proxy configuration.
> > > >> NPM registry could be down temporarily.
> > > >>
> > > >> Byoungro So
> > > >> SSG / DPD / Mobile Computing and Compilers
> > > >> Intel Corporation
> > > >>
> > > >> From: "Pridham, Marcus" <marcus.pridham@sap.com<mailto:
> > > >> marcus.pridham@sap.com>>
> > > >> Reply-To: "dev@cordova.apache.org<mailto:dev@cordova.apache.org>"
<
> > > >> dev@cordova.apache.org<mailto:dev@cordova.apache.org>>
> > > >> Date: Thursday, March 3, 2016 at 7:19 AM
> > > >> To: "dev@cordova.apache.org<mailto:dev@cordova.apache.org>"
<
> > > >> dev@cordova.apache.org<mailto:dev@cordova.apache.org>>
> > > >> Subject: Re: Cannot add/find cordova-ios 4.1.0
> > > >>
> > > >> Deleting the ~/.cordova folder fixes the issue for me.
> > > >>
> > > >>
> > > >>
> > > >>
> > > >> On 3/3/16, 4:56 AM, "Alexis Kofman" <alexis.kofman@gmail.com
> <mailto:
> > > >> alexis.kofman@gmail.com>> wrote:
> > > >>
> > > >> Hello guys !
> > > >>
> > > >> Same here with the last Android version :
> > > >>
> > > >> $ cordova platform add ios@5.1.1<mailto:ios@5.1.1>
> > > >> Error: Failed to fetch platform ios@5.1.1<mailto:ios@5.1.1>
> > > >> Probably this is either a connection problem, or platform spec is
> > > >> incorrect.
> > > >> Check your connection and platform name/version/URL.
> > > >> Error: version not found: cordova-ios@5.1.1<mailto:
> cordova-ios@5.1.1>
> > > >>
> > > >>
> > > >>
> > > >> On Thu, Mar 3, 2016 at 10:45 AM, Zarko Hristovski <zarko@binaris.no
> > > >> <mailto:zarko@binaris.no>> wrote:
> > > >>
> > > >> Using cordova 6.0.0
> > > >>
> > > >> cordova create test_ios && cd test_ios && cordova
platform add
> > ios@4.1.0
> > > >> <mailto:ios@4.1.0>
> > > >>
> > > >> yields
> > > >>
> > > >> Creating a new cordova project.
> > > >> Error: Failed to fetch platform ios@4.1.0<mailto:ios@4.1.0>
> > > >> Probably this is either a connection problem, or platform spec is
> > > >> incorrect.
> > > >> Check your connection and platform name/version/URL.
> > > >> Error: version not found: cordova-ios@4.1.0<mailto:
> cordova-ios@4.1.0>
> > > >>
> > > >>
> > > >> I thought cordova-ios 4.1.0 was released!?
> > > >>
> > > >> https://www.npmjs.com/package/cordova-ios
> > > >>
> > > >>
> > > >>
> ---------------------------------------------------------------------
> > > >> To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org<mailto:
> > > >> dev-unsubscribe@cordova.apache.org>
> > > >> For additional commands, e-mail: dev-help@cordova.apache.org
> <mailto:
> > > >> dev-help@cordova.apache.org>
> > > >>
> > > >>
> > > >>
> > > >>
> > > >> --
> > > >> Alexis Kofman
> > > >>
> > > >>
> > > >>
> ---------------------------------------------------------------------
> > > >> To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
> > > >> For additional commands, e-mail: dev-help@cordova.apache.org
> > > >>
> > > >
> > >
> >
>



-- 
Alexis Kofman

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message