cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tobias Bocanegra <tri...@apache.org>
Subject [DISCUSS] Only allow `osx-package` in feature element
Date Fri, 12 Feb 2016 19:18:16 GMT
Hi,

with the upcoming release of OSX some of the plugins will also support OSX.
currently they are added via the `ios-package` in the plugin.xml (eg
[0]). the current parser in OSX allows both names, ios-package and
osx-package.

maybe we should be more strict and only allow osx-package [1] in order
to avoid confusion and potential conflicts.

I suggest:
- we allow both for now
- we change the plugins that currently support osx to use the
osx-package attribute name
- we remove the support for ios-package in the next, 4.1, release.

WDYT?
regards, toby


[0] https://github.com/apache/cordova-plugin-file/blob/master/plugin.xml#L256
[1] https://issues.apache.org/jira/browse/CB-10602

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org


Mime
View raw message