cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nikhilkh <>
Subject [GitHub] cordova-lib pull request: CB-10644 Adds deprecation message about ...
Date Thu, 18 Feb 2016 20:56:13 GMT
Github user nikhilkh commented on a diff in the pull request:
    --- Diff: cordova-lib/src/platforms/platforms.js ---
    @@ -48,11 +48,17 @@ function getPlatformApi(platform, platformRootDir) {
         var PlatformApi;
         try {
             // First we need to find whether platform exposes its' API via js module
    -        // If it has, then we have to require it and extend BasePlatformApi
    -        // with platform's API.
    +        // If it does, then we require and instantiate it.
             var platformApiModule = path.join(platformRootDir, 'cordova', 'Api.js');
             PlatformApi = require(platformApiModule);
         } catch (err) {
    +        // Check if platform already compatible w/ PlatformApi and show deprecation warning
    +        if (err && err.code === 'MODULE_NOT_FOUND' && platforms[platform].apiCompatibleSince)
    +            events.emit('warn', 'The support for cordova-' + platform + ' via PlatformApi
polyfill ' +
    --- End diff --
    instead of leaking internal implementation detail we should consider re-phrasing this
    "Using this version of cordova CLI with older version of cordova-<platform> is being
deprecated. Consider upgrading to..."

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message