cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Kotikov (Akvelon)" <>
Subject [DISCUSS] Old platforms support deprecation
Date Fri, 22 Jan 2016 14:58:36 GMT
Hi guys.

Starting from upcoming cordova release (6.0.0) we have PlatformApi implemented and used by
three major platforms (Android, iOS and Windows). This means that we now have a lot of code
in cordova-lib which exists there only for maintaining compatibility with previous platforms
versions.  I'd love to remove this duplicates from lib, but this means that we'll lose the
support for previous platforms in newer cli, and hence we'd need to deprecate this support

So I propose to add a deprecation message about removing support for old platforms into upcoming
cordova@6.0.0 and remove this support totally in next major cordova version (7.0.0). The message
will be emitted each time when polyfill is instantiated for these platforms instead of platform's
Api class and might look like this:

"The support for old platforms via PlatformApi polyfill is deprecated and will be removed
in next versions of cordova.
Consider upgrading your platform to cordova-android@5.0.0 or newer."

Best regards, Vladimir.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message