cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven Gill <stevengil...@gmail.com>
Subject Re: [DISCUSS] Revert Cordova plugins to work with default pinned versions
Date Wed, 25 Nov 2015 20:45:42 GMT
I think it is more reasonable to get users to explicitly update their
cordova-android to 5 than it is to get people who are using
cordova-android@5 now to be explicit about adding plugins versions which
are higher than what npm shows (assuming we set latest back to previous
release).

Most people want to and should be supporting marshmallow.

In the case you describe above about installing the camera plugin and it
failing, it isn't a silent failure. Users get notified that the version of
camera doesn't support their version of android and they should
update. Users using cordova-android 5 don't get such a nice failure message
for using older plugins that don't support the new permission model.
Instead they realize at runtime. Much worse.

Now, the reason why I am willing to revert the `latest` tag for those 5
plugins (file, media, camera, contacts, geolocation) to previous releases
is the case you brought up in slack. Visual studio grabs latest plugins and
can't get a update out quickly. We can revert those until we get cordova@6
out.

I think this is more an issue with VS and less with cordova. Cordova should
not be backtracking releases due to downstreams. The discuss thread for
plugins came out 19 days ago. We have been chatting about this release for
even longer than that!

If we do this, I want to be very clear that it is a special exception.
Cordova should not be doing this again. It is up to Visual studio to be
prepared for releases. It is not cordova's responsibility.

With pinning plugins landing in cordova@6, this hopefully won't be an issue
anymore. I hope to get cordova@6 out in a couple of weeks. At that time,
latest will once again be switched for those 5 plugins. VS and other
downstream, please be prepared for it.





Hi,

The latest Cordova plugin release [1] has some plugins like camera,
contacts, files, geolocation, etc. that require mailto:cordova-android@5.0.0
to work. The latest released version of Cordova-cli does not pin mailto:
cordova-android@5.0.0, but instead pins cordova-android@4.1.1.

Scenario
- User adds android platform using cordova platform add android - he gets
cordova-anrdoid@4.1.1
- User now adds the camera plugin - cordova plugin add camera - gets the
version of the camera plugin that works only with cordova-android@5.0

This combination does not work and the scenario breaks.

I do understand that there are many folks who are already using
cordova-android@5 for marshmallow support, and that we need to release the
versions of plugins that support marshmallow. However, these folks already
add the cordova-android@5.0 platform by explicitly specifying a version
number. Hence, it would be reasonable to expect them to also add the
supported plugins by specifying a version number.
For folks who still add platforms and plugins without specifying version
numbers, I think we should ensure that the scenario continues to work.


Fix
I think the way to fix this issue would be to still have the verisons of
plugins that support cordova-android@5.0 released, but the "latest" should
point to the versions that cordova-cli has pinned.

[1] https://cordova.apache.org/news/2015/11/24/plugins-release.html

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message