cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jesse <purplecabb...@gmail.com>
Subject Re: [Android][Discuss] Change name of CordovaWebView to CordovaWebInterface
Date Sat, 24 Oct 2015 04:02:54 GMT
it is!


My team is hiring!
@purplecabbage
risingj.com

On Fri, Oct 23, 2015 at 7:15 PM, Carlos Santana <csantana23@gmail.com>
wrote:

> +1 if what Simon and Jesse are saying is the same thing :-)
>
>
> On Fri, Oct 23, 2015 at 7:42 PM Jesse <purplecabbage@gmail.com> wrote:
>
> > Let's go ahead with renaming CordovaWebView => CordovaWebInterface, and
> > keeping around a CordovaWebView object so that nothing breaks.
> >
> > We should also deprecate CordovaWebView, and document the change so that
> > people who are using it have some notice, and people who are new know
> what
> > NOT to use.
> >
> > We don't have to remove it immediately, or even on our next major bump,
> > just sometime down the road.
> > If we don't move forward we will just be stuck with it forever ...
> >
> >
> >
> >
> > My team is hiring!
> > @purplecabbage
> > risingj.com
> >
> > On Fri, Oct 23, 2015 at 1:19 PM, Nikhil Khandelwal <
> nikhilkh@microsoft.com
> > >
> > wrote:
> >
> > > I understand that it won't break currently and it will break on the
> next
> > > major version bump. IMHO it's just not worth it for this name change.
> > >
> > > Historically, we've had challenges with giving sufficient notice from
> > > breaking changes. I would avoid them unless absolutely needed.
> > >
> > > -Nikhil
> > >
> > > -----Original Message-----
> > > From: Simon MacDonald [mailto:simon.macdonald@gmail.com]
> > > Sent: Thursday, October 22, 2015 12:14 PM
> > > To: dev@cordova.apache.org
> > > Subject: Re: [Android][Discuss] Change name of CordovaWebView to
> > > CordovaWebInterface
> > >
> > > Let's just be clear that in Cordova Android 5.0 nothing will break.
> > > The interface CordovaWebView has been renamed to CordovaWebInterface
> but
> > > that won't break anything as we introduce a new class called, wait for
> > it,
> > > CordovaWebView that extends the new CordovaWebInterface. This way all
> > > current code that uses CordovaWebView will continue to work without
> > > modification.
> > >
> > > If we start updating our documentation, i.e. how to write a
> CordovaPlugin
> > > for Android, and give people plenty of notice that this is going to
> > happen
> > > then I don't see why we wouldn't want to move forward.
> > >
> > > That's just my 2 cents.
> > >
> > > Simon Mac Donald
> > >
> > >
> >
> https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fhi.im%2fsimonmacdonald&data=01%7c01%7cnikhilkh%40microsoft.com%7caf6077fb55224d7b1d2c08d2db1508fe%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=50aLt1e0sp9z4TrrSBiMnAaBdSj1RrUuIEcnPaHGD1U%3d
> > >
> > >
> > > On Wed, Oct 21, 2015 at 6:13 PM, Nikhil Khandelwal <
> > nikhilkh@microsoft.com>
> > > wrote:
> > > > Thanks, Joe for the summary of the impact later.
> > > >
> > > > -1. IMO - a naming change is no worth the effort and future breakage.
> > > >
> > > > -Nikhil
> > > >
> > > > -----Original Message-----
> > > > From: Joe Bowser [mailto:bowserj@gmail.com]
> > > > Sent: Wednesday, October 21, 2015 11:06 AM
> > > > To: dev <dev@cordova.apache.org>
> > > > Subject: Re: [Android][Discuss] Change name of CordovaWebView to
> > > > CordovaWebInterface
> > > >
> > > > Yes, I do.  I had to search through mobilespec, but here it is:
> > > >
> > > > private static final boolean HAS_BUILT_IN_SPLASH_SCREEN =
> > > > Integer.valueOf(CordovaWebView.CORDOVA_VERSION.split("\\.")[0]) < 4;
> > > >
> > > > Also, every plugin that calls initialize requires a CordovaWebView
> > > passed into it.  That's a pretty big change.  I also haven't touched on
> > > Third Party WebViews like Crosswalk, which would have to do the change.
> > > >
> > > >
> > > > On Tue, Oct 20, 2015 at 1:59 PM, Steven Gill <stevengill97@gmail.com
> >
> > > wrote:
> > > >
> > > >> Joe, do you have a small example of what could break with this
> change.
> > > >> What is a usecase for someone to reference CordovaWebView
> > > >>
> > > >> On Tue, Oct 20, 2015 at 1:38 PM, Joe Bowser <bowserj@gmail.com>
> > wrote:
> > > >>
> > > >> > I'll pull this in at the end of the day.  This small change may
> > > >> > break
> > > >> stuff
> > > >> > further down the road, so people should comment on it now.
> > > >> >
> > > >> > On Tue, Oct 20, 2015 at 1:37 PM, Joe Bowser <bowserj@gmail.com>
> > > wrote:
> > > >> >
> > > >> > > OK, Going to pull this in.
> > > >> > >
> > > >> > > On Tue, Oct 20, 2015 at 10:02 AM, Simon MacDonald <
> > > >> > > simon.macdonald@gmail.com> wrote:
> > > >> > >
> > > >> > >> +1 from me as I'm the one that initiated the PR.
> > > >> > >>
> > > >> > >> Simon Mac Donald
> > > >> > >>
> https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2f
> > > >> > >> h
> > > >> > >> i.im%2fsimonmacdonald&data=01%7c01%7cnikhilkh%40microsoft.com
> %7c
> > > >> > >> 8
> > > >> > >>
> 619031b1eef484bd48508d2da425e41%7c72f988bf86f141af91ab2d7cd011db
> > > >> > >> 4
> 7%7c1&sdata=IXoWw2z2L7EhCorf4kK4EJ7Ux89hdUjmP%2bKsF%2bJdwf0%3d
> > > >> > >>
> > > >> > >> On Tue, Oct 20, 2015 at 12:23 PM, Darryl Pogue
> > > >> > >> <darryl@dpogue.ca>
> > > >> > wrote:
> > > >> > >>
> > > >> > >> > +1 for doing this with the major version bump
> > > >> > >> >
> > > >> > >> > On 20 October 2015 at 09:15, Joe Bowser <bowserj@gmail.com>
> > > wrote:
> > > >> > >> >
> > > >> > >> > > Hey
> > > >> > >> > >
> > > >> > >> > > We're close to getting 5.0.x ready for release,
but I want
> > > >> > >> > > to add
> > > >> > one
> > > >> > >> > more
> > > >> > >> > > pull request:
> > > >> > >> > >
> > > >> > >> > >
> https://na01.safelinks.protection.outlook.com/?url=https%3a%
> > > >> > >> > > 2
> > > >> > >> > > f%2fgithub.com
> %2fapache%2fcordova-android%2fpull%2f227&data=
> > > >> > >> > > 0
> > > >> > >> > > 1%7c01%7cnikhilkh%40microsoft.com
> %7c8619031b1eef484bd48508d2
> > > >> > >> > > d
> > > >> > >> > >
> a425e41%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=w5TYcbC
> > > >> > >> > > H %2fhLIhbrZImOsVFgGMfp%2bIk0Dl6Qk6ADzMVc%3d
> > > >> > >> > >
> > > >> > >> > > This is a trivial pull request, but I want
to get buy-in
> > > >> > >> > > from the
> > > >> > list
> > > >> > >> > for
> > > >> > >> > > doing the rename for CordovaWebView class
to be changed
> > > >> > >> > > before we
> > > >> > >> start
> > > >> > >> > > deprecating it.  This means we're probably
going to remove
> > > >> > >> > > the
> > > >> shim
> > > >> > in
> > > >> > >> > the
> > > >> > >> > > next major version.
> > > >> > >> > >
> > > >> > >> > > Thoughts?
> > > >> > >> > >
> > > >> > >> > > Joe
> > > >> > >> > >
> > > >> > >> >
> > > >> > >>
> > > >> > >
> > > >> > >
> > > >> >
> > > >>
> > > >
> > > > ---------------------------------------------------------------------
> > > > To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
> > > > For additional commands, e-mail: dev-help@cordova.apache.org
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
> > > For additional commands, e-mail: dev-help@cordova.apache.org
> > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message