cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shazron <>
Subject Re: [DISCUSS] CocoaPods dependencies for iOS plugins
Date Mon, 19 Oct 2015 23:23:12 GMT
This is not a platform specific issue, at least for cordova-ios, and
is the domain of the cordova-lib/cli currently (I think the
cordova-lib re-factor changes this?)

There will be a cordova-discuss doc, but the gist of it is:

    <engine name="cocoapods" version=">=0.39.0"  platform="ios" />
    <engine name="nuget" version=">=3.2" platform="windows" />

<framework src="path/to/mypod.podspec" type="podspec" />
<framework src="path/to/mynu.nuspec" type="nuspec" />

The above use existing documented attributes for both the <engine> and
<framework> tags:

On Sat, Oct 17, 2015 at 11:56 PM, Steven Gill <> wrote:
> At the Cordova F2F, everyone seemed to agree that we should bring CocoaPods
> support to plugins as dependencies for iOS.
> Cordova-android currently uses Gradle as a way to enable external
> dependency resolution for plugins using the framework tag.
> A suggestion about using the engine tag to fetch cocoapods-cli (mac) &
> NuGet (windows) followed by using the framework tag was discussed.
> The minutes[1] show Carlos, Shaz and Raghav as looking into the design.
> Someone should write up a proposal on cordova-discuss[2] and create the
> issues. Post them in this thread.
> This shouldn't take priority over cordova-ios 4 issues.
> [1]
> [2]

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message