cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shazron <>
Subject [Proposal][iOS] Drop support for iOS 7
Date Mon, 21 Sep 2015 18:28:23 GMT
We tend to have this discussion every year. We've typically supported
the current iOS version and one version back. This would mean just
supporting iOS 9 and 8.

I propose to drop support for iOS 7.

This doesn't mean Cordova won't run on an iOS 7 device, but this means
we won't test whether Cordova or the plugins run on it (i.e. not crash
if they use a newer API).

There is only one change required: Increasing the minimum
DEPLOYMENT_TARGET to 8.0 in the new project template/xcconfig.

According to Apple, 52% of devices are using iOS 9 already, and 41%
are on iOS 8. 8% of users are on earlier iOS versions. (Yeah the math
adds up to 101%??)

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message