cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nikhil Khandelwal <nikhi...@microsoft.com>
Subject RE: cordova-plugin-whitelist ios issue
Date Wed, 30 Sep 2015 00:37:52 GMT
I think the first version of the whitelist plugin was released without the corodva-ios 4.0
check, so that developers do not see this warning because cordova-ios 4.0 was not released.
I agree with Tommy, that the wording of the warning seems to suggest there is a way for me
to fix this issue:
"Plugin doesn't support this project's cordova-ios version. cordova-ios: 3.9.1, failed version
requirement: >=4.0.0-dev."

However, with this plugin we do not have a way to fix it because ios 4.0 is not released.


I suggest we do the following:
- Unpublish the version that has a dependency on ios 4.x
- Release cordova-plugin-whitelist v2 which has an ios 4.x depdency
- In the tools release, that pins cordova-ios 4.x we should ship a cordova-app-hello-world
template that targets v2 of this plugin.

Thanks,
Nikhil

-----Original Message-----
From: Shazron [mailto:shazron@gmail.com] 
Sent: Tuesday, September 29, 2015 5:28 PM
To: dev@cordova.apache.org
Subject: Re: cordova-plugin-whitelist ios issue

This is only happening because we have two engine requirements - cordova-android 4.x and cordova-ios
4.x. This is correct for cordova-plugin-whitelist.

Like I mentioned before, cordova-android+ios 3.x *do not* require this plugin as it is built
in. Perhaps this could be communicated better, but the warning is generic, and there's no
way to communicate this in an <engine> tag.

We could release core plugins that have different core platform version requirements as well
in the future (like android 5 plugin
changes) and this will occur again.


On Tue, Sep 29, 2015 at 5:21 PM, Shazron <shazron@gmail.com> wrote:
> "IMO we should never release a plugin which always emits a warning 
> that cannot be resolved."
>
> There is nothing to resolve. The resolution is to ignore it. It's 
> supposed to warn you, as it is working as expected.
>
> On Tue, Sep 29, 2015 at 5:19 PM, Nikhil Khandelwal 
> <nikhilkh@microsoft.com> wrote:
>> I understand the warning w.r.t. plugins and android 5.0 as we will release android
5.0 along with the plugin update and there would be a path for people to resolve the warning.
>>
>> In this case, ios 4.0 is not even released and users have no way to work around this
warning. We're getting feedback from customers about this.
>>
>> IMO we should never release a plugin which always emits a warning that cannot be
resolved.
>>
>> -Nikhil
>>
>> -----Original Message-----
>> From: Shazron [mailto:shazron@gmail.com]
>> Sent: Tuesday, September 29, 2015 5:17 PM
>> To: dev@cordova.apache.org
>> Subject: Re: cordova-plugin-whitelist ios issue
>>
>> No its not a "rogue version". cordova-plugin-whitelist requires cordova-ios 4.0 and
cordova-android 4.0.
>> It's just a warning and is expected to work this way.
>> https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fgith
>> ub.com%2fapache%2fcordova-plugin-whitelist%2fblob%2fmaster%2fREADME.m
>> d&data=01%7c01%7cnikhilkh%40microsoft.com%7cd638675115ae4fa7be2d08d2c
>> 92c9d89%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=iO9NDS0BgD53OVED
>> yxGv0zNW5SKXLVK0loo8ZAEmfOM%3d
>>
>> On Tue, Sep 29, 2015 at 5:08 PM, Nikhil Khandelwal <nikhilkh@microsoft.com>
wrote:
>>> 1.       cordova create test
>>>
>>> 2.       cordova platform add ios
>>>
>>> WARNING: Applications for platform ios can not be built on this OS - win32.
>>> Adding ios project...
>>> iOS project created with cordova-ios@3.9.1 Discovered plugin 
>>> "cordova-plugin-whitelist" in config.xml. Installing to the project 
>>> Fetching plugin "cordova-plugin-whitelist@1" via npm Installing 
>>> "cordova-plugin-whitelist" for ios Plugin doesn't support this 
>>> project's cordova-ios version. cordova-ios: 3.9.1, failed version
>>> requirement: >=4.0.0-dev Skipping 'cordova-plugin-whitelist' for ios 
>>> Installing "cordova-plugin-whitelist" for ios Plugin doesn't support 
>>> this project's cordova-ios version. cordova-ios: 3.9.1, failed 
>>> version
>>> requirement: >=4.0.0-dev Skipping 'cordova-plugin-whitelist' for ios
>>>
>>> Looks like we have a rogue version of cordova-plugin-whitelist published that
requires iOS 4.0.0. What's the best way to fix it? Can we unpublish this whitelist plugin
version from npm to fix this? Alternatively, we should release another version of the plugin
that does not get this warning. It's misleading and confusing for developers to see this warning.
>>>
>>> Thanks,
>>> Nikhil
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
>> For additional commands, e-mail: dev-help@cordova.apache.org
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
>> For additional commands, e-mail: dev-help@cordova.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org
Mime
View raw message