cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nikhil Khandelwal <nikhi...@microsoft.com>
Subject RE: cordova-plugin-whitelist ios issue
Date Wed, 30 Sep 2015 00:19:31 GMT
I understand the warning w.r.t. plugins and android 5.0 as we will release android 5.0 along
with the plugin update and there would be a path for people to resolve the warning.

In this case, ios 4.0 is not even released and users have no way to work around this warning.
We're getting feedback from customers about this.

IMO we should never release a plugin which always emits a warning that cannot be resolved.

-Nikhil

-----Original Message-----
From: Shazron [mailto:shazron@gmail.com] 
Sent: Tuesday, September 29, 2015 5:17 PM
To: dev@cordova.apache.org
Subject: Re: cordova-plugin-whitelist ios issue

No its not a "rogue version". cordova-plugin-whitelist requires cordova-ios 4.0 and cordova-android
4.0.
It's just a warning and is expected to work this way.
https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fgithub.com%2fapache%2fcordova-plugin-whitelist%2fblob%2fmaster%2fREADME.md&data=01%7c01%7cnikhilkh%40microsoft.com%7cd638675115ae4fa7be2d08d2c92c9d89%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=iO9NDS0BgD53OVEDyxGv0zNW5SKXLVK0loo8ZAEmfOM%3d

On Tue, Sep 29, 2015 at 5:08 PM, Nikhil Khandelwal <nikhilkh@microsoft.com> wrote:
> 1.       cordova create test
>
> 2.       cordova platform add ios
>
> WARNING: Applications for platform ios can not be built on this OS - win32.
> Adding ios project...
> iOS project created with cordova-ios@3.9.1 Discovered plugin 
> "cordova-plugin-whitelist" in config.xml. Installing to the project 
> Fetching plugin "cordova-plugin-whitelist@1" via npm Installing 
> "cordova-plugin-whitelist" for ios Plugin doesn't support this 
> project's cordova-ios version. cordova-ios: 3.9.1, failed version 
> requirement: >=4.0.0-dev Skipping 'cordova-plugin-whitelist' for ios 
> Installing "cordova-plugin-whitelist" for ios Plugin doesn't support 
> this project's cordova-ios version. cordova-ios: 3.9.1, failed version 
> requirement: >=4.0.0-dev Skipping 'cordova-plugin-whitelist' for ios
>
> Looks like we have a rogue version of cordova-plugin-whitelist published that requires
iOS 4.0.0. What's the best way to fix it? Can we unpublish this whitelist plugin version from
npm to fix this? Alternatively, we should release another version of the plugin that does
not get this warning. It's misleading and confusing for developers to see this warning.
>
> Thanks,
> Nikhil

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org
Mime
View raw message