cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bowser <bows...@gmail.com>
Subject [Android] CB-9479: Gradle, Lint and Conditionals
Date Tue, 11 Aug 2015 17:47:50 GMT
Hey

I'm currently working on a way to make Cordova-Android distributable by AAR
so that we can further abstract everything out and make it easier for Java
developers to use Cordova instead of rolling their own hacked up WebViews.
Of course, this means that our code has to pass Lint, and it doesn't.

Most of the errors we can ignore because Lint sucks at reading conditional
logic, but there's one that refuses to be ignored, which is the Gradle
conditional that allows Cordova to use preview versions of the Android
Gradle plugin.

Of course, since Android Studio was pre-1.0, we were really working on it
from pressure from our users to drop Eclipse like a hot rock, but now I'm
wondering if we should keep this conditional, or if we ever need to use it
now that things with Android Studio have stabilized.

Here's the compatibility page for Gradle and Android Studio:
http://tools.android.com/tech-docs/new-build-system/version-compatibility

Any thoughts on this issue?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message