cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shazron <shaz...@gmail.com>
Subject [cordova-lib] Tests require cordova-android devDependencies being updated?
Date Thu, 20 Aug 2015 18:59:20 GMT
Firstly I updated all my repos by running:
coho repo-update -r all

Then, I tried to run "npm test" on cordova-lib on master and I got some
failures:
--------------------------
Failures:
  1) (save flag) platform add --save spec.1 should support custom tgz files
   Message:
     timeout: timed out after 60000 msec waiting for spec to complete
  2) (save flag) platform add --save spec.7 should save git url with git
ref properly
   Message:
     Expected false to be true.
  3) (save flag) platform update --save spec.11 should update spec with git
url when updating using git url
--------------------------

Not sure what was going on. I nuked `node_modules` and ran `npm install`
again in `cordova-lib`, I still get the same failures.

At Steve Gill's prompting, I updated the `cordova-android` repo by running
`npm install` in the sibling directory, then ran `npm test` again for
cordova-lib, and this time all the tests pass.

Based on this evidence, I think cordova-lib has a dependency on
cordova-android somehow? If so, why should it? (which means downloading the
cordova-lib repo and running tests won't work).

Note that I did not have Android installed on my computer either.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message