cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vldmrrr <vldm...@gmail.com>
Subject Re: [DISCUSS] cordova-windows release
Date Wed, 26 Aug 2015 17:05:53 GMT
I finally tried running mobilespec  on my system, it fails with the same 
error when building from command line for windows10, BUT when I tried 
building from VS IDE, it builds fine, and does pass app cert kit. Same 
goes about my test hello app. Good enough as far as I am concerned

On 8/23/2015 1:10 AM, Rob Paveza wrote:
> I'm not sure what you're seeing.  I definitely saw that with the older versions, but
I'm not seeing that on the release version.  CB-9524 is fixed, I'll update that.
>
> I just validated it at home as well.
>
> Do you have the latest version of Visual Studio and Win10 tools?  The .NET Native stuff
came in really late, but this is what I get as my output:
> -----
> Building project: F:\cordova\mobilespec\platforms\windows\CordovaApp.Windows10.jsproj
>          Configuration : release
>          Platform      : x64
>    Starting .NET Native compilation
>    C:\Windows\Microsoft.NET\Framework\v4.0.30319\Csc.exe /noconfig /unsafe+ /pdb:F:\cordova\mobilespec\platforms\windows\build\windows\bld\ilc\intermediate\org.apache.m
>    obilespec.pdb /nostdlib+ /reference:"C:\Program Files (x86)\MSBuild\Microsoft\.NetNative\x64\ilc\lib\Private\System.Private.CoreLib.dll"
/debug:full /out:F:\cordova\
>    mobilespec\platforms\windows\build\windows\bld\ilc\intermediate\org.apache.mobilespec.exe
/target:winexe F:\cordova\mobilespec\platforms\windows\build\windows\bld\il
>    c\intermediate\fake.cs
>    Processing application code
> C:\Program Files (x86)\MSBuild\Microsoft\.NetNative\x64\ilc\IlcInternals.targets(789,5):
warning : Your application is missing a Runtime Directives (rd.xml) file. Runt
> ime Directives are used to describe the dynamic behavior of your application and control
the .NET Native optimizer. It is recommended to have at least one rd.xml file
> in your project. [F:\cordova\mobilespec\platforms\windows\CordovaApp.Windows10.jsproj]
>    Computing application closure and generating interop code
>    Compiling interop code
>    Generating serialization code
>    Cleaning up unreferenced code
>    Running native compilers
>    Generating fixups for native code
>    Compilation successful.
>
>    CordovaApp.Windows10 -> F:\cordova\mobilespec\platforms\windows\AppPackages\CordovaApp.Windows10_0.0.1.0_x64_Test\CordovaApp.Windows10_0.0.1.0_x64.appx
>   BUILD OUTPUT: F:\cordova\mobilespec\platforms\windows\AppPackages\CordovaApp.Windows10_0.0.1.0_x64_Test\CordovaApp.Windows10_0.0.1.0_x64.appx
>
> Deploying windows10 package to device:
> F:\cordova\mobilespec\platforms\windows\AppPackages\CordovaApp.Windows10_0.0.1.0_x64_Test\CordovaApp.Windows10_0.0.1.0_x64.appx
> Attempt to uninstall previous application version...
> Attempt to install application...
> Found package: F:\cordova\mobilespec\platforms\windows\AppPackages\CordovaApp.Windows10_0.0.1.0_x64_Test\CordovaApp.Windows10_0.0.1.0_x64.appx
>
> Installing app...
> Found dependency package(s):
> F:\cordova\mobilespec\platforms\windows\AppPackages\CordovaApp.Windows10_0.0.1.0_x64_Test\Dependencies\x86\Microsoft.NET.Native.Runtime.1.1.appx
> F:\cordova\mobilespec\platforms\windows\AppPackages\CordovaApp.Windows10_0.0.1.0_x64_Test\Dependencies\x86\Microsoft.VCLibs.x86.14.00.appx
> F:\cordova\mobilespec\platforms\windows\AppPackages\CordovaApp.Windows10_0.0.1.0_x64_Test\Dependencies\x64\Microsoft.NET.Native.Runtime.1.1.appx
> F:\cordova\mobilespec\platforms\windows\AppPackages\CordovaApp.Windows10_0.0.1.0_x64_Test\Dependencies\x64\Microsoft.VCLibs.x64.14.00.appx
>
> Success: Your app was successfully installed.
> Starting application...
> ActivateApplication:  org.apache.mobilespec_h35559jr9hy9m!org.apache.mobilespec
> -----
> Mobilespec contains the globalization plugin as well and I also created a new app to
validate (I'm on a different computer too than the one than I authored the release from).
 WACK passed on all of these.
>
> It just looks to me like you're running into a problem with the .NET Native compiler
as it's installed on your system.  If you want I can try to get someone to work with you to
figure out what's going on.
>
> -Rob

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org


Mime
View raw message