cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Victor Sosa <sosah.vic...@gmail.com>
Subject Re: Supported Git version
Date Thu, 23 Jul 2015 17:10:07 GMT
Now I understand. Thanks.
Jesse, do you know the JIRA in which you worked this problem?

On Wed, Jul 22, 2015 at 5:27 PM Jesse <purplecabbage@gmail.com> wrote:

> Yes, we absolutely need to be able to install plugins via github url and
> support branches/tags/commit-sha as part of the url.  Also, sub-folders
> within github repos.
>
> The feature I removed was the 'git version checking bs' [1]
>
> Carlos, npm supports installing from github too[2].  I'm not sure why you
> recommend dropping that as it is great for trying different combos.
>  ie. platformA+pluginB@unpublished-version.
>
>
> [1]
>
> https://github.com/apache/cordova-lib/commit/9af173a65281e9ea87fc6da3ee0b9f10bb8fec1c
> [2] https://docs.npmjs.com/cli/install
>
>
>
>
>
> My team is hiring!
> @purplecabbage
> risingj.com
>
> On Wed, Jul 22, 2015 at 3:00 PM, Darryl Pogue <darryl@dpogue.ca> wrote:
>
> > Thanks for clarifying :)
> >
> > On 22 July 2015 at 14:53, Steven Gill <stevengill97@gmail.com> wrote:
> >
> > > To clarify, we aren't removing installing from git. It is totally
> > > important.
> > >
> > > Jesse fixed a problem with not being able to install from git when you
> > > point to specific commit. This was do the --depth flag being used. He
> > > recently removed the use of --depth and this may fix the git 1 vs 2
> > issues
> > > Victor is seeing.
> > >
> > > On Wed, Jul 22, 2015 at 2:30 PM, Darryl Pogue <darryl@dpogue.ca>
> wrote:
> > >
> > > > Support for installing from git URLs for plugins is a pretty
> important
> > > > requirement for us as end users.
> > > >
> > > > On 22 July 2015 at 14:21, Carlos Santana <csantana23@gmail.com>
> wrote:
> > > >
> > > > > +1 only npm id or local path should be supported
> > > > > On Wed, Jul 22, 2015 at 5:16 PM Victor Sosa <
> sosah.victor@gmail.com>
> > > > > wrote:
> > > > >
> > > > > > Wait a minute, Jesse? what you mean by "I removed this
> 'feature'"?
> > > What
> > > > > > feature are you referring to?
> > > > > >
> > > > > > On Wed, Jul 22, 2015 at 3:50 PM Jesse <purplecabbage@gmail.com>
> > > wrote:
> > > > > >
> > > > > > > No idea, but, I just removed this 'feature' as there were
> errors
> > > with
> > > > > > > checking out a particular tag or commit.
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > > On Jul 22, 2015, at 1:29 PM, Victor Sosa <
> > sosah.victor@gmail.com
> > > >
> > > > > > wrote:
> > > > > > > >
> > > > > > > > Hello community.
> > > > > > > >
> > > > > > > > I've been playing a little with Cordova on simple
scenarios,
> > and
> > > > > > noticed
> > > > > > > > that when using Git 2.x I get this error when installing
a
> > plugin
> > > > > from
> > > > > > a
> > > > > > > > Git repo from GitHub
> > > > > > > > https://github.com/apache/cordova-plugin-contacts.git
> > > > > > > >
> > > > > > > > The error is:
> > > > > > > > *Error: git: Command failed with exit code 128 Error
output:*
> > > > > > > > *Cloning into '/tmp/git/1436905601736'...*
> > > > > > > > *fatal: dumb http transport does not support --depth
*
> > > > > > > >
> > > > > > > > However, when using 1.9.x I have no problems installing
the
> > > plugin.
> > > > > > > >
> > > > > > > > I've been looking at the docs but I can't find a single
> mention
> > > of
> > > > > > > > supported Git version. Does anyone happen to know
the answer
> of
> > > > this?
> > > > > > > >
> > > > > > > > BTW, using Cordova 5.1.1
> > > > > > >
> > > > > > >
> > > ---------------------------------------------------------------------
> > > > > > > To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
> > > > > > > For additional commands, e-mail: dev-help@cordova.apache.org
> > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message