cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven Gill <stevengil...@gmail.com>
Subject Re: [DISCUSS] Tools release
Date Thu, 25 Jun 2015 03:09:08 GMT
I agree with Shaz about the engine fix. As we move on, more and more
plugins could start requiring a minimum version of a certain platform. It
is a bug in cordova lib to throw an error when a requirement isn't met.
Instead a warning about skipping that plugin should be expected behavior.

Until the tools release is out, I could set the latest tag on the whitelist
plugin to the previous release so new users don't have to deal with the bug
without having an option to update their tools.
On Jun 24, 2015 6:02 PM, "Shazron" <shazron@gmail.com> wrote:

> Also CB-5898 and CB-6441 fixes related to plugins not
> installing/uninstalling properly (which has been a long time annoyance)
>
> On Wed, Jun 24, 2015 at 4:40 PM, Shazron <shazron@gmail.com> wrote:
>
> > This is a bug in the CLI that was fixed, and not a bug in the plugin.
> >
> > On Wed, Jun 24, 2015 at 4:38 PM, Nikhil Khandelwal <
> nikhilkh@microsoft.com
> > > wrote:
> >
> >> Would it not be better to remove the iOS implementation from the
> >> whitelist plugin, so that it's install can be successful all the people
> >> using iOS 3.8 and Android 4.0?
> >>
> >> When iOS 4.0 release happens, this support could be added back.
> >>
> >> Thanks,
> >> Nikhil
> >>
> >>
> >> -----Original Message-----
> >> From: Jesse [mailto:purplecabbage@gmail.com]
> >> Sent: Wednesday, June 24, 2015 1:05 PM
> >> To: dev@cordova.apache.org
> >> Subject: Re: [DISCUSS] Tools release
> >>
> >> Do it!
> >>
> >>
> >>
> >> My team is hiring!
> >> @purplecabbage
> >> risingj.com
> >>
> >> On Wed, Jun 24, 2015 at 11:11 AM, Shazron <shazron@gmail.com> wrote:
> >>
> >> > +1++
> >> >
> >> > On Wed, Jun 24, 2015 at 10:35 AM, Steven Gill <stevengill97@gmail.com
> >
> >> > wrote:
> >> >
> >> > > I'd like to get a tools release out that has the fix for skipping
a
> >> > plugin
> >> > > if the platform version isn't met. The recently released whitelist
> >> > > plugin requires ios 4.0 and will fail installation if it isn't met.
> >> > > You notice this when installing multiple plugins at once. I fixed
> >> > > plugin install to properly skip installing when platform check fails
> >> > > and continue with
> >> > other
> >> > > plugin installs.
> >> > >
> >> > > Cordova-lib/cli 5.2.0
> >> > > Plugman 0.24.0
> >> > > Cordovajs 4.1.0
> >> > >
> >> >
> >>
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message