cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From huz's gmail <huiqingzhou1...@gmail.com>
Subject [cordova-lib] nom version too old, cannot use cnpm @scoped syntax
Date Fri, 26 Jun 2015 21:55:37 GMT
Hi, Dear Cordova Team,

	I’m in a dilemma where i’d like to publish company private cordova plugins using cnpm:
https://github.com/cnpm/cnpmjs.org <https://github.com/cnpm/cnpmjs.org> while its syntax
is rejected by cordova-cli’s (5.1.1) npm max version: 1.3.4
	I understand that there’re other issues open trying to upgrade the outdated npm version
for other support, just like to put this to the table as well.

	cordova plugin add @company/pluginid 

	After some debugging, i’ve located the issue as the npm 1.3.4 doesn’t support @scoped
syntax till: https://github.com/npm/npm/issues/5239 <https://github.com/npm/npm/issues/5239>

Much Thanks,
Roy
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message