cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Murat Sutunc <mura...@microsoft.com>
Subject RE: npm install cordova fails due to JSONStream dependency
Date Thu, 07 May 2015 18:11:58 GMT
This is a major issue in NPM !!
 
There is a thread going on at github: https://github.com/npm/npm/issues/7195
"browserify versions 5.0.0 - 10.1.1 (10.1.2 is the latest) can't be installed because of JSONStream
vs jsonstream on OS X and windows"

The real issue is browserify has a dependency on module-deps and JSONStream:
- browserify 7.1.0 has dependency on JSONStream 0.8.4
- browserify 7.1.0 has dependency on module-deps ^3.6.3
- module-deps 3.7.11 has dependency on jsonstream ^1.0.3

JSONStream and jsonstream are two separate repos. Lowercase jsonstream starts at version 1.0.0
and mixed case doesn't have any 1.0.0 version. npm install gets confused fails to install
because it can't find both versions of the package in the same repo.

All the Cordova versions which depend on this version of browserify is currently broken!

-----Original Message-----
From: Steven Gill [mailto:stevengill97@gmail.com] 
Sent: Thursday, May 7, 2015 10:45 AM
To: dev@cordova.apache.org
Subject: Re: npm install cordova fails due to JSONStream dependency

Nikhil, what version of npm are you using?
On May 7, 2015 10:21 AM, "Jesse" <purplecabbage@gmail.com> wrote:

> Yeah, it is browserify's dependency on JSONStream and a recent change 
> to npm that does not like package names with capital letters.
>
> browserify has fixed it by changing their use from JSONStream to 
> jsonstream, however we are on a much older version of browserify, and 
> can't simply update to the most recent.
>
> Probably we just need to give npm an hour or two to work it out.
>
>
> @purplecabbage
> risingj.com
>
> On Thu, May 7, 2015 at 9:59 AM, Nikhil Khandelwal 
> <nikhilkh@microsoft.com>
> wrote:
>
> > This is breaking npm install of all recent versions of cordova:
> >
> > λ npm install cordova
> > npm WARN engine cordova-js@3.9.0: wanted: {"node":"~0.10.x"} (current:
> > {"node":"0.12.0","npm":"2.5.1"})
> > npm WARN engine npm@1.3.4: wanted: {"node":">=0.6","npm":"1"} (current:
> > {"node":"0.12.0","npm":"2.5.1"})
> > npm WARN engine xmlbuilder@2.2.1: wanted: {"node":"0.8.x || 0.10.x"}
> > (current: {"node":"0.12.0","npm":"2.5.1"}) npm ERR! Windows_NT 
> > 6.3.9600 npm ERR! argv "C:\\Program Files (x86)\\nodejs\\\\node.exe" 
> > "C:\\Program Files 
> > (x86)\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install"
> "cordova"
> > npm ERR! node v0.12.0
> > npm ERR! npm  v2.5.1
> > npm ERR! code ETARGET
> >
> > npm ERR! notarget No compatible version found: JSONStream@'>=1.0.3
> <2.0.0'
> > npm ERR! notarget Valid install targets:
> > npm ERR! notarget
> >
> ["0.0.0","0.1.0","0.1.1","0.1.2","0.1.3","0.2.0","0.2.1","0.2.2","0.2.
> 3","0.3.0","0.3.1","0.3.2","0.3.3","0.4.0","0.4.1","0.4.2","0.4.3","0.
> 4.4","0.5.0","0.6.0","0.6.1","0.6.2","0.6.3","0.6.4","0.7.0","0.7.1","
> 0.8.0","0.7.2","0.7.3","0.7.4","0.8.1","0.8.2","0.8.3","0.8.4","0.9.0"
> ,"0.10.0"]
> > npm ERR! notarget
> > npm ERR! notarget This is most likely not a problem with npm itself.
> > npm ERR! notarget In most cases you or one of your dependencies are 
> > requesting npm ERR! notarget a package version that doesn't exist.
> >
> > npm ERR! Please include the following file with any support request:
> > npm ERR!     d:\apps\test\npm-debug.log
> >
> > Our browserify dependency is at the heart of the problem:
> > https://github.com/substack/node-browserify/issues/1249 but I don't 
> > understand enough of npm dependency management to figure out how 
> > this can be resolved. I'm still digging into this.
> >
> > Thanks,
> > Nikhil
> >
> >
> >
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org


Mime
View raw message