cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven Gill <stevengil...@gmail.com>
Subject Re: [DISCUSS] Rapid release of tools
Date Thu, 07 May 2015 20:18:46 GMT
I have already published cordova-js@3.9.1 and cordova-lib@5.0.1 under the
RC flag before I saw your message. I will unpublish them, delete tags,
revert commits, etc. :(



On Thu, May 7, 2015 at 1:16 PM, Steven Gill <stevengill97@gmail.com> wrote:

> Looks like they just fixed the issue by using an older version of npm to
> publish JSONStream 1.0.2 and 1.0.3. No need for a release! Woot!
>
> FTR, I don't think the hotfix would have caused any issues for us as long
> as they kept browserify 10.1.2 around.
>
>
>
> On Thu, May 7, 2015 at 1:01 PM, Murat Sutunc <muratsu@microsoft.com>
> wrote:
>
>> Wait guys. I think we should hold on for a sec.
>>
>> There are 3 possible scenarios:
>> 1- We bump up our dependencies, latest version of Cordova is fixed but
>> older ones remain broken.
>> 2- Browserify and/or module-deps can roll back (unpublish perhaps). Which
>> will fix the issue for all cordova until npm makes the fix.
>> 3- NPM makes a quick fix.
>>
>> If we bump Cordova and browserify and module-deps decides to roll back,
>> we'll be in trouble. I think the correct approach here is to talk with NPM
>> and see what they suggest. If they commit on fixing this issue asap,
>> browserify and module-deps can rollback and republish once everything is
>> fixed. If you look at browserify and module-deps, using lowercase repos is
>> a pretty recent change and there's probably less dependencies out there
>> than Cordova.
>>
>> -----Original Message-----
>> From: Steven Gill [mailto:stevengill97@gmail.com]
>> Sent: Thursday, May 7, 2015 12:47 PM
>> To: dev@cordova.apache.org
>> Subject: Re: [DISCUSS] Rapid release of tools
>>
>> i'm working on getting the release ready
>>
>> On Thu, May 7, 2015 at 12:37 PM, Shazron <shazron@gmail.com> wrote:
>>
>> > +1 release off previous, with this one change only.
>> >
>> > On Thu, May 7, 2015 at 12:07 PM, Steven Gill <stevengill97@gmail.com>
>> > wrote:
>> > > I am thinking we release off our previous release branches with this
>> > > one change. This needs to get out asap. I'm all for an accelerated
>> vote.
>> > >
>> > >
>> > >
>> > > On Thu, May 7, 2015 at 12:05 PM, Jesse <purplecabbage@gmail.com>
>> wrote:
>> > >
>> > >> Given that all downstream distributions are broken currently, can
>> > >> we do
>> > an
>> > >> accelerated vote?
>> > >> Are we introducing any other code that would slow us down? or can
>> > >> we
>> > simply
>> > >> update+republish package.json files?
>> > >>
>> > >> @purplecabbage
>> > >> risingj.com
>> > >>
>> > >> On Thu, May 7, 2015 at 12:01 PM, Steven Gill
>> > >> <stevengill97@gmail.com>
>> > >> wrote:
>> > >>
>> > >> > I think we should do a quick release to get npm install cordova
>> > working
>> > >> > again asap.
>> > >> >
>> > >> > I have updated the browserify dependency on cordova-js which
>> > >> > fixes the problem.
>> > >> >
>> > >> > Need to release cordova-js@3.9.1, cordova-lib@5.0.1,
>> > cordova-cli@5.0.1
>> > >> and
>> > >> > plugman@0.23.2 with the new dependency.
>> > >> >
>> > >>
>> >
>> > ---------------------------------------------------------------------
>> > To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
>> > For additional commands, e-mail: dev-help@cordova.apache.org
>> >
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
>> For additional commands, e-mail: dev-help@cordova.apache.org
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message