cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shazron <shaz...@gmail.com>
Subject Re: [ios-sim] beta-4.0, help test
Date Sat, 16 May 2015 16:51:33 GMT
Thanks Julio!

The physical device not showing thing might be a cordova-ios bug
("ios-deploy -c" does list  the devices) -- i'll log it
The multiple times thing is already a JIRA issue.

I'll log also the 'cordova emulate --target "iPhone-5s, 8.3"' bug as well

On Sat, May 16, 2015 at 8:47 AM, julio cesar sanchez
<jcesarmobile@gmail.com> wrote:
> I've just tested and *cordova run --list* doesn't show any physical device,
> just the virtual devices, and every device appears multiple times (once per
> installed sdk version but doesn't show the version) and as you say, you
> can't choose which version you want to run with cordova emulate --target
> "iPhone-5s, 8.3"
>
> *ios-sim showdevicetypes*  shows all the devices showing the iOS version
> *ios-sim start --devicetypeid "iPhone-5s, 8.1"* starts the iOS simulator
> with the selected iOS version
>
> If you want me to test anything else let me know
>
> 2015-05-15 3:03 GMT+02:00 Shazron <shazron@gmail.com>:
>
>> One major difference is ios-sim 4.x is a pure node.js tool, that uses
>> a node.js wrapper library I wrote for Xcode's simctl utility:
>> https://github.com/phonegap/simctl
>>
>> Still MIT license, and was written from scratch and didn't use any of
>> the old code.
>>
>>
>> On Thu, May 14, 2015 at 5:58 PM, Shazron <shazron@gmail.com> wrote:
>> > Hi,
>> >     npm install -g ios-sim@beta-4.0
>> >
>> > I intend to time the release to coincide with cordova-ios 4.0.x's
>> > release when the time comes.
>> >
>> > Some options have been removed, some are unimplemented (the
>> > unimplemented ones are not criticial for Cordova) as of version 4.1.0.
>> >
>> > See the docs:
>> >      https://github.com/phonegap/ios-sim/tree/4.x
>> >
>> > I lightly tested this with:
>> >      cordova emulate
>> >      cordova emulate --target "iPhone-5s"
>> >      cordova run --list   // double listing fix is in 5.0-dev for
>> > multiple runtimes
>> >
>> > However specifying the runtime as well doesn't work, this is a bug in
>> > cordova-ios:
>> >
>> >      cordova emulate --target "iPhone-5s, 8.3"
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
>> For additional commands, e-mail: dev-help@cordova.apache.org
>>
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org


Mime
View raw message