cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nikhil Khandelwal <nikhi...@microsoft.com>
Subject RE: [BUG] Fail to build Mobilespec with --thirdpartyplugins (CB-9032)
Date Thu, 28 May 2015 00:59:41 GMT
Joe, Andrew, Ian, Michael: I'm hoping one of you can plug this documentation gap since you
are most knowledgeable about changes from Cordova-android 3.7 to 4.0.

Thanks,
Nikhil


-----Original Message-----
From: Joe Bowser [mailto:bowserj@gmail.com] 
Sent: Friday, May 15, 2015 4:23 PM
To: dev@cordova.apache.org
Subject: Re: [BUG] Fail to build Mobilespec with --thirdpartyplugins (CB-9032)

I agree.  This is something that I believe that is in the tracker.  The real problem with
this is that we have no idea what our public API looks like for plugin developers, or any
documentation as to what the best practices for plugin developers are.  As far as regular
non-plugin devs are concerned, we didn't actually have a breaking API change for Cordova-Android
4.0.0 other than the whitelists, which we made into a plugin.

One of the things that we actually fixed/improved in Cordova-Android 4.0, the third-party
Java dependencies, has no documentation, and we're basically directing people to Crosswalk
as the way to do this.  We should really be adding the documentation, and if anyone wants
to take that on, that'd be awesome.

On Fri, May 15, 2015 at 4:06 PM Nikhil Khandelwal <nikhilkh@microsoft.com>
wrote:

> Is there a list of cordova-android 4.0 APIs that have been removed? I 
> think a migration guide from Androind 3.7.1 => Androind 4.0.0 would be 
> super useful.
>
> Thanks,
> Nikhil
>
>
> -----Original Message-----
> From: Joe Bowser [mailto:bowserj@gmail.com]
> Sent: Friday, May 15, 2015 7:02 AM
> To: dev@cordova.apache.org
> Subject: Re: [BUG] Fail to build Mobilespec with --thirdpartyplugins
> (CB-9032)
>
> Hey
>
> I just took a look at those, and those are all the methods we decided 
> to remove when we changed the API for Cordova-Android 4.0.  We have no 
> plans on bringing those methods back, so I'm going to close the issue.  
> I recommend filing issues with those repositories to get them to 
> update their plugins to the current API.
>
> On Fri, May 15, 2015 at 1:37 AM Lin, Wanming <wanming.lin@intel.com>
> wrote:
>
> > Hello,
> >
> > It is failed to build Mobilespec with "--thirdpartyplugins" on 
> > Cordova CLI
> > 5.0.0 and latest commit of cordova-mobile-spec.
> > I've filed a JIRA bug: 
> > https://issues.apache.org/jira/browse/CB-9032,
> > could anyone help take a look? Many thanks in advance!
> >
> > Thanks,
> > Wanming
> >
> > --------------------------------------------------------------------
> > - To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
> > For additional commands, e-mail: dev-help@cordova.apache.org
> >
> >
>
Mime
View raw message