cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Homer, Tony" <tony.ho...@intel.com>
Subject Re: Platform guides update
Date Thu, 09 Apr 2015 21:02:44 GMT
I have more of a general topic - cordova-windows vs. cordova-wp8 in the
docs.
Hopefully most of us on the list understand the distinction, but there is
still a lot of confusion.
There are some places where the docs could help make the distinction a bit
clearer.

For example, in the plugin development guide, the list of native
interfaces includes Windows Phone 8 plugins and Windows plugins.
For those of use in the know, Windows Phone 8 maps to cordova-wp8 and
Windows maps to cordova-windows.
However, many users read those bullets as the native platforms, not as the
cordova platforms.
It would be nice to make this distinction as clear as possible.

Similarly on the platform guides page it would be great to clarify the
difference between the cordova windows platforms and the native windows
platforms.
This has been done very nicely on the Windows platform guide page, but
there is nothing to help users on the top-level platform guide page.
Also on the Windows Phone 8 page, it would be nice if there was a notice
at the top helping users know that they probably want to look at the
Windows guide for Windows Phone 8.1 development.

I see this as an important customer-facing issue - I¹ve had recent
conversations with people that want to support Windows Phone in plugins
and think they should be using C#.

Sorry I¹m not as succinct as Shazron :p

On 4/9/15, 4:23 PM, "Shazron" <shazron@gmail.com> wrote:

>iOS:
>1. Xcode 4.x -> 6.x
>2. Also add ios-deploy required to deploy to device
>3. ok
>
>On Tue, Apr 7, 2015 at 12:01 PM, Sergey Grebnov (Akvelon)
><v-segreb@microsoft.com> wrote:
>> Hi guys, I see that some docs are outdated or not actual anymore so I
>>want to improve this. Please let me know if someone already working on
>>this or going to take a look. I've listed below some things I want to
>>update, could you please review them before I stared working on this
>>(additional suggestions and ideas are very welcome)
>>
>> iOS:
>>     1. Xcode 4.x->5.x
>>     2. Add information about ios-sim required to deploy app from
>>command line
>>     3. Add information how to list available deploy targets and run app
>>on specific target/device
>>
>> Android:
>>    1. Add changes in favor of replacing Ant w/ Gradle
>>        a. Remove Ant from requirements
>>        b. Replace Eclipse example w/ Android Studio as officially
>>recommended option/tool
>>    2.  Add more details about particular Android packages/components
>>required to be installed.
>>         Android 5.0.1 (API 21) platform SDK
>>         Android SDK Build-tools version 19.1.0 or higher
>>         Android Support Repository (Extras)
>>     3. Add information how to list available deploy targets and run app
>>on specific target/device
>>
>> Windows:
>>     1. Remove 'To develop apps for Windows 8.0 only:'
>>     2. Hardware requirements to run Windows Phone emulator (Client
>>Hyper-V and Second Level Address Translation (SLAT))
>>     3. Add information how to list available deploy targets and run app
>>on specific target/device
>>
>> Thx!
>> Sergey
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
>> For additional commands, e-mail: dev-help@cordova.apache.org
>>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
>For additional commands, e-mail: dev-help@cordova.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org


Mime
View raw message