cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bowser <bows...@gmail.com>
Subject Re: Deprecation Wars: ICS vs Gingerbread
Date Wed, 22 Apr 2015 21:33:06 GMT
BTW: Sorry for rushing the commit and sticking the ugly merge commit to try
and fix it.

On Wed, Apr 22, 2015 at 2:28 PM Steven Gill <stevengill97@gmail.com> wrote:

> Okay. Since pluggable webviews don't work with 2.3.x, I'd say we do a
> cordova-android 4.1.0 release with minsdk 14.
>
> I'll update the docs to say we only support android 4+
>
> On Wed, Apr 22, 2015 at 2:24 PM, Joe Bowser <bowserj@gmail.com> wrote:
>
> > As in they don't work on Android 2.3.x, sorry hit send way too soon.
> Also,
> > there's a lot of bad security issues on 2.3.x that we just can't fix, so
> > it's best that we draw the line here and not support 2.3.x
> >
> > On Wed, Apr 22, 2015 at 2:23 PM Joe Bowser <bowserj@gmail.com> wrote:
> >
> > > None of the Third Party WebViews work for 4.0.x
> > >
> > > On Wed, Apr 22, 2015 at 2:19 PM Steven Gill <stevengill97@gmail.com>
> > > wrote:
> > >
> > >> 4.1.0? Is the minsdk the only thing keeping gingerbread support
> around?
> > >> Are
> > >> there other things about 4.0.0 that broke support for 2.3.0?
> > >>
> > >>
> > >>
> > >> On Wed, Apr 22, 2015 at 2:13 PM, Joe Bowser <bowserj@gmail.com>
> wrote:
> > >>
> > >> > OK, because we screwed up, should we release a Cordova-Android 5.0?
> > >> This
> > >> > is going to break people, even though I don't care about the
> breakage,
> > >> I do
> > >> > care about telling them about the breakage.
> > >> >
> > >> > Thoughts?
> > >> >
> > >> > On Wed, Apr 22, 2015 at 2:10 PM Joe Bowser <bowserj@gmail.com>
> wrote:
> > >> >
> > >> > > It should be replaced with 14.  This was definitely an oversight
> > >> since we
> > >> > > all agreed in theory but never came to a proper decision.
> > >> > >
> > >> > > On Wed, Apr 22, 2015 at 12:20 PM Sergey Grebnov (Akvelon) <
> > >> > > v-segreb@microsoft.com> wrote:
> > >> > >
> > >> > >> I still see minSdkVersion = 10 (GINGERBREAD) in platform
> template.
> > >> > Should
> > >> > >> it be replaced w/ 14 (ICE_CREAM_SANDWICH) in this case and
also
> > >> updated
> > >> > in
> > >> > >> platform docs? -  per docs we still support Gingerbread.
> > >> > >>
> > >> > >> Steve is currently working on docs update so this is perfect
time
> > to
> > >> > >> change this.
> > >> > >>
> > >> > >> -Sergey
> > >> > >> -----Original Message-----
> > >> > >> From: Shazron [mailto:shazron@gmail.com]
> > >> > >> Sent: Tuesday, April 21, 2015 1:04 PM
> > >> > >> To: dev@cordova.apache.org
> > >> > >> Subject: Re: Deprecation Wars: ICS vs Gingerbread
> > >> > >>
> > >> > >> Joe, perhaps that can be part of the Tools Release blog post?
> Steve
> > >> put
> > >> > >> out a link to the draft in another thread.
> > >> > >>
> > >> > >> On Tue, Apr 21, 2015 at 10:14 AM, Joe Bowser <bowserj@gmail.com>
> > >> wrote:
> > >> > >> > Resurrecting this thread!
> > >> > >> >
> > >> > >> > I think we need to let our users know that Cordova 4.0
doesn't
> > >> support
> > >> > >> > Gingerbread, or at least some of the features don't
work on
> > >> > Gingerbread.
> > >> > >> > I've been trying to clean up the JIRA a bit today, and
it seems
> > >> that
> > >> > >> > while we came to a consensus to drop 2.3, we didn't
tell
> anyone.
> > :/
> > >> > >> >
> > >> > >> >
> > >> > >> > On Tue, Jan 13, 2015 at 12:41 PM Joe Bowser <bowserj@gmail.com
> >
> > >> > wrote:
> > >> > >> >
> > >> > >> >> Firefox works on 2.3, and Chrome does not. It also
depends on
> > the
> > >> > >> >> device
> > >> > >> >>
> > >> > >> >> On Tue, Jan 13, 2015, 12:20 PM Josh Soref <
> > jsoref@blackberry.com>
> > >> > >> wrote:
> > >> > >> >>
> > >> > >> >>> Michal Mocny wrote:
> > >> > >> >>> >... we aren't telling those individuals
that they cannot use
> > >> their
> > >> > >> >>> >phones, we are telling developers that want
to create new
> > >> > >> >>> >applications for that target to either build
mobile web,
> > >> packaged
> > >> > >> >>> >native, or just stick to existing versions
of cordova if
> > really
> > >> > >> needed.
> > >> > >> >>> >
> > >> > >> >>> >I do not buy the argument that you are doing
those
> individuals
> > >> with
> > >> > >> >>> >those phones a favour by building them hybrid
apps using the
> > >> > >> >>> >antiquated 2.3 webview on antiquated machine
specs.
> > >> > >> >>>
> > >> > >> >>> I don't have an opinion on this. But I do have
a question.
> > >> > >> >>>
> > >> > >> >>> Ignoring the fact that GeckoView is flaky today,
> > >> > >> >>>
> > >> > >> >>> 1. Does GeckoView / Firefox work (at all? well?)
on a sample
> /
> > >> > >> >>> typical 2.3 device?
> > >> > >> >>> 2. Can I run Chrome (or some relative) on that
same device
> (at
> > >> all?
> > >> > >> >>> well?)
> > >> > >> >>>
> > >> > >> >>
> > >> > >>
> > >> > >>
> > ---------------------------------------------------------------------
> > >> > >> To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
> > >> > >> For additional commands, e-mail: dev-help@cordova.apache.org
> > >> > >>
> > >> > >>
> > >> > >>
> > ---------------------------------------------------------------------
> > >> > >> To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
> > >> > >> For additional commands, e-mail: dev-help@cordova.apache.org
> > >> > >>
> > >> > >
> > >> >
> > >>
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message