cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shazron <shaz...@gmail.com>
Subject Re: ios devices never show up with --list
Date Tue, 14 Apr 2015 20:08:19 GMT
Seems to me a regression.
When I ran the old bash script from 3.7.0, it lists it fine:
https://raw.githubusercontent.com/apache/cordova-ios/3.7.0/bin/templates/scripts/cordova/lib/list-devices

On Tue, Apr 14, 2015 at 12:55 PM, Carlos Santana <csantana23@gmail.com> wrote:
> When I run cordova run ios --device --list is always empty
>
> $ cordova run ios --device --list
> Available ios devices:
>
> Any special requirement I need to make this to work?
>
> Looking at the code this is not using ios-deploy to list the ios devices
> plug to usb.
>
> Is using [1] something weird like: system_profiler SPUSBDataType | sed -n
> -e \'/iPad/,/Serial/p\' | grep "Serial Number:" | awk -F ": " \'{print $2 "
> iPad"}\''
>
> I'm running Yosemite 10.10.2
>
> [1] :
> https://github.com/apache/cordova-ios/blob/master/bin/templates/scripts/cordova/lib/list-devices#L33
>
> I can run ios-deploy and see the device is connected.
>
> $ ios-deploy -c
> [....] Waiting up to 5 seconds for iOS device to be connected
> [....] Found iPhone 6 Plus 'Carlos iPhone'
> (863d93714ea635453646d23e2dccf4fbd5986ad0) connected through USB.
>
> --
> Carlos Santana
> <csantana23@gmail.com>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@cordova.apache.org
For additional commands, e-mail: dev-help@cordova.apache.org


Mime
View raw message