cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bowser <>
Subject Renaming CordovaWebView CordovaWebInterface
Date Wed, 14 Jan 2015 00:25:14 GMT
So, this was something that was brought up numerous times, but I think we
should probably discuss this at least one more time before we move to
finish off 4.0.x.

Given that we're breaking the API for CordovaWebView already, would it make
sense for us to call it a CordovaWebInterface instead? The class has been
changed to an interface, and this would changing it in the Plugin API, but
it would make it more clear what we intend to do with this method in the

What do people think? Should we rename this, or keep it the way it is so
that we keep most of the plugins, including third party plugins working
with 4.0.x, and then do the breakage in 5.0.x.

Note: I want the timeframe between 4.0.x and 5.0.x to be a lot shorter.
There's a lot of iterations that people want to do on this, and we should
release major releases a little more often than once a year for Android,
but that's for another thread.



  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message