cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Grieve <agri...@chromium.org>
Subject Re: How to test the cordova-android 4.0 by mobile spec
Date Wed, 07 Jan 2015 17:59:39 GMT
Went to try this out and decided it's a bad idea. Much better is to just
fix createmobilespec.js to use the proper platform versions when generating
the .js. I've done this and checked it in.

On Wed, Jan 7, 2015 at 10:45 AM, Andrew Grieve <agrieve@chromium.org> wrote:

> Hmm, I hadn't tried the key event manual tests with 4.0.x in MS. I do
> think that would break based on the version being MSTEST, since there is
> now code to make an exec() to CoreAndroid based on the platformVersion.
>
> Maybe let's just set the plugin bridge name back to "App" on 4.0.x so that
> the js exec() will always work (but still leave the class name as
> "CoreAndroid")
>
> On Tue, Jan 6, 2015 at 10:06 PM, Fu, Junwei <junwei.fu@intel.com> wrote:
>
>> Yes, I set up mobilespec following
>> https://github.com/apache/cordova-mobile-spec .
>>
>> -----Original Message-----
>> From: Joe Bowser [mailto:bowserj@gmail.com]
>> Sent: Wednesday, January 07, 2015 10:54 AM
>> To: dev@cordova.apache.org
>> Subject: Re: How to test the cordova-android 4.0 by mobile spec
>>
>> So, it's not using the cordova that's installed locally via npm? I'll
>> have to check that again.
>>
>> On Tue Jan 06 2015 at 6:33:14 PM Andrew Grieve <agrieve@chromium.org>
>> wrote:
>>
>> > I've just been checkout out 4.0.x branch of cordova-android, then
>> > running the script. I think the script requires that
>> > cordova-mobile-spec, cordova-android, and cordova-js all be sibling
>> directories.
>> >
>> > On Tue, Jan 6, 2015 at 7:58 PM, Joe Bowser <bowserj@gmail.com> wrote:
>> >
>> > > I haven't been able to get mobile-spec working reliably since it was
>> > > refactored and we were forced to use the createmobilespec.sh script
>> (i.e.
>> > > Tests don't run on Android 2.3) How did you manage to get it to work
>> > > with 4.0.x?
>> > >
>> > > On Tue Jan 06 2015 at 6:24:51 AM Andrew Grieve
>> > > <agrieve@chromium.org>
>> > > wrote:
>> > >
>> > > > I think you had it right. use cordova-mobile-spec@master and
>> > > > cordova-android@4.0.x. Failing tests are likely issues (in android
>> > > > or
>> > in
>> > > > the tests). Just fixed last night that the JS on 4.0.x was not
>> > > > properly registering with the CoreAndroid plugin due to it being
>> > > > renamed, so
>> > that
>> > > > could be the cause of the key event test failing.
>> > > >
>> > > > On Tue, Jan 6, 2015 at 3:47 AM, Fu, Junwei <junwei.fu@intel.com>
>> > wrote:
>> > > >
>> > > > > Hi,
>> > > > >
>> > > > > Because There are no cordova-mobile-spec  4.0 branch, so I used
>> > > > > cordova-mobile-spec master branch to test cordova-android 4.0,
>> > > > > but
>> > the
>> > > > key
>> > > > > event test cases failed. And the splash screen test cases failed
>> > > > > with cordova-mobile-spec 3.6 branch, I don't know how to test
>> > > > > the cordova-android 4.0 by mobile spec.
>> > > > >
>> > > > > Thanks,
>> > > > > Junwei.
>> > > > >
>> > > >
>> > >
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message