cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Koudritsky <>
Subject Re: MobileSpec for testing cordova-lib@rc
Date Thu, 08 Jan 2015 21:09:04 GMT
On Thu, Jan 8, 2015 at 3:47 PM, Michal Mocny <> wrote:

> If we add node_modules to search path, will we be able to adjust which
> versions of platforms/plugins it uses just by modifying package.json?
Since platforms can be added by path. You can replace
platforms = ['android']
platforms = ['/path/to/local/cordova-android']   // Should work for using
e.g. cordova-android 4.x
platforms = ['../node_modules/cordova-android']

> Not sure if platforms use search path, or just plugins?  Also not sure if
> we can install plugins from our registry using npm proper, but you can use
> the git repos as a workaround if not.

For plugins it's more tricky (other npm repo, different dependency model).
Some options are:
 - use private cordova subsection in package.json and store plugin info
including versions there in whatever format  we want

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message