cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fu, Junwei" <junwei...@intel.com>
Subject RE: minSdkVersion conflict
Date Tue, 09 Dec 2014 02:13:10 GMT
Thank you very much.

I will add the documentation of this approach for xwalk library.

-----Original Message-----
From: Mark Koudritsky [mailto:kamrik@google.com] 
Sent: Monday, December 08, 2014 9:57 PM
To: dev@cordova.apache.org
Subject: Re: minSdkVersion conflict

If you you add this line to cordova project config.xml <preference name="android-minSdkVersion"
value="14" /> It should set the same value in AndroidManifest.xml during prepare.

The code that deals with it is in
cordova-lib/src/cordova/metadata/android_parser.js
starting at line 259

On Mon, Dec 8, 2014 at 1:59 AM, Fu, Junwei <junwei.fu@intel.com> wrote:

> Hi,
>
> The Cordova project minSdkVersion is 10, the xwalk library is 14, it 
> will show the following error when compile with Gradle.
>
> > ./test/AndroidManifest.xml:0:0 Error:
> >             uses-sdk:minSdkVersion 10 cannot be smaller than version 
> > 14
> declared in library org.xwalk:xwalk_core_library_beta:9.38.208.4
> > :processArmv7DebugManifest FAILED
>
> I found a workaround from https://gist.github.com/goldierox/9533466, 
> it replace the minSdkVersion by Gradle task.
>
> Is it an good approach to solute this issue, Do you have better approach?
> Thanks,
> Junwei.
>
Mime
View raw message