cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Grebnov (Akvelon)" <v-seg...@microsoft.com>
Subject RE: windows universal problems 3.6
Date Sat, 06 Sep 2014 12:43:59 GMT
Hi Staci, thx for the details. We are aware of these issues, Vladimir (in CC) has been working
on them and will provide more details on Monday.

Thx!
Sergey
-----Original Message-----
From: Staci Cooper [mailto:staci.mcl@gmail.com] 
Sent: Friday, September 5, 2014 11:06 PM
To: dev@cordova.apache.org
Subject: windows universal problems 3.6

I tried building mobile-spec for the windows universal platform and I've run into a handful
of problems with the wp8.1 project. Is anybody else seeing this behavior?


   - Some of the plugins are causing problems if checked out from the
   registry. For example, if I include the device plugin checked out at the
   latest version from the registry, deviceready does not fire
   - When all plugins are checked out at master, if the media plugin is
   added, I get this error: " File content does not conform to specified
   schema. The element 'Capabilities' in namespace '
   http://schemas.microsoft.com/appx/2010/manifest' has invalid child
   element 'Capability' in namespace '
   http://schemas.microsoft.com/appx/2010/manifest'."
   It is basically the same as this resolved issue
   <https://issues.apache.org/jira/browse/CB-5350> with camera and
   geolocation in windows8; Capability elements must go before
   DeviceCapability elements in the manifest. The capabilties for camera and
   geolocation are sorted properly, but "<Capability Name='musicLibrary' />"
   needs to be moved up.
   - Again with all plugins on master, I see a lot of problems with
   mobilespec. The app crashes when running the auto test-framework tests or
   manual tests for battery-status, inappbrowser, and bridge. The contacts
   tests fail, as do the file-transfer tests related to images (video is
   working), many of the dialogs tests, etc etc.


All of this is testing with the wp8.1 project. Anyone else seeing this or have I got something
configured incorrectly?
Mime
View raw message