cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jesse <purplecabb...@gmail.com>
Subject Re: [Vote] 3.6.1 Cadence Release (redo of 3.6.0)
Date Sat, 06 Sep 2014 00:17:11 GMT
The npm publish path for cordova-windows and cordova-wp8 is hopelessly
broken in a world where we are not using --usegit as the default.

There were many requirements added by using npm as the main distribution
mechanism that weren't considered. Namely, cordova-wp8 and cordova-windows
both used include multiple platforms so the root of the repo is NOT the
root of the platform.

In order for me to resolve these issues, I will need to change cordova-wp8,
cordova-windows, cordova-lib, and cordova-plugman

I think we have to consider this vote thread dead.
-1





@purplecabbage
risingj.com


On Fri, Sep 5, 2014 at 4:15 PM, Jesse <purplecabbage@gmail.com> wrote:

> Okay, thanks to Carlos!
>
> CI is green for master and 3.6.x
>
> I have retagged 3.6.x current HEAD as 3.6.1 and we can rebuild the
> packages for those only.
>
> I am seeing an issue with the tarballs for windows+wp8
> The repos both need to be packaged from the root of the repo, and not the
> child folder windows/wp8 respectively.
>
> I am not sure if this is a coho packaging issue, or if there is something
> else that Steve does, but I will look into the coho stuff so we can get
> this process to be so simple we can release and vote every 3 days ....
>
>
> @purplecabbage
> risingj.com
>
>
> On Fri, Sep 5, 2014 at 2:35 PM, Carlos Santana <csantana23@gmail.com>
> wrote:
>
>> +1 on having CI for platforms repos
>>
>>
>> On Fri, Sep 5, 2014 at 5:34 PM, Carlos Santana <csantana23@gmail.com>
>> wrote:
>>
>> > Jesse need to make up your mind on node_modules
>> >
>> > there is a diff between master and 3.6.x
>> >
>> > Need to make a decision on where you want "node_modules" with the
>> checkin
>> > files
>> > either in root along side package.json, or if inside bin\node_modules
>> then
>> > need to remove the "dependencies and bundleDependecies" from
>> package.json
>> >
>> > Also the error is related to missing files inside
>> "node_modules/nopt/bin"
>> > the top .gitignore is ignoring "bin" so "nopt\bin" is not present in git
>> >
>> >
>> >
>> > On Fri, Sep 5, 2014 at 5:18 PM, Jesse <purplecabbage@gmail.com> wrote:
>> >
>> >> I am on it. node_modules issue
>> >>
>> >> cordova-windows also has appveyor smoke tests
>> >>
>> >> @purplecabbage
>> >> risingj.com
>> >>
>> >>
>> >> On Fri, Sep 5, 2014 at 2:12 PM, Marcel Kinard <cmarcelk@gmail.com>
>> wrote:
>> >>
>> >> > Is this something you can look at, or are you out of time because of
>> >> your
>> >> > move and could use some help?
>> >> >
>> >> > On Sep 5, 2014, at 4:58 PM, Jesse <purplecabbage@gmail.com> wrote:
>> >> >
>> >> > > WP8 build is failing
>> >> > > https://ci.appveyor.com/project/Humbedooh/cordova-wp8
>> >> >
>> >> >
>> >>
>> >
>> >
>> >
>> > --
>> > Carlos Santana
>> > <csantana23@gmail.com>
>> >
>>
>>
>>
>> --
>> Carlos Santana
>> <csantana23@gmail.com>
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message