cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Santana <csantan...@gmail.com>
Subject Re: Confused about Android API level and Cordova, does it support anything less than 19
Date Wed, 24 Sep 2014 21:06:36 GMT
Adding to Joe's remarks.
Don't let minSDK and targetSDK confuse you.
More info here:
http://developer.android.com/guide/topics/manifest/uses-sdk-element.html

Your app running on a device using API 17 should be OK if you use the
Cordova defaults (i.e. target 19, min 10) because 17 is between 10 and 19 ;p

On Wed, Sep 24, 2014 at 5:02 PM, Joe Bowser <bowserj@gmail.com> wrote:

> I've said this 1000 times, and I'll say it again.
>
> Cordova is compiled to the latest API level, and works on Android 2.3 to
> 4.4.3.  It even works on L, but we recommend building with the latest
> stable API level, which API 19.  When we say it's backwards compatible, we
> mean that you can run this on Gingerbread to KitKat.  You should have
> absolutely no reason to change that setting.  The only reason that setting
> is configurable is because Android will increment versions, and people will
> use old versions of Cordova that may or may not be future-proof.
>
>
>
> On Wed, Sep 24, 2014 at 1:11 PM, Mark E. Scott Jr. <mscott@scott-usa.com>
> wrote:
>
> > I can't find any way to get it to work without having API level 19 or
> > greater installed.  It doesn't appear to be backwards compatible to 10
> like
> > the platform guide for android indicates.
> >
> > I simplified things such that I only had a single API level present, that
> > being 17.
> >
> > Mark
> >
> > -----Original Message-----
> > From: brian.leroux@gmail.com [mailto:brian.leroux@gmail.com] On Behalf
> Of
> > Brian LeRoux
> > Sent: Wednesday, September 24, 2014 3:04 PM
> > To: dev@cordova.apache.org
> > Subject: Re: Confused about Android API level and Cordova, does it
> support
> > anything less than 19
> >
> > NEVER LET IT HAPPEN AGAIN
> >
> > (jk)
> >
> > np, Mark. also: API level should be backwards compat so having at 19
> means
> > 17 *should* work but please let us know if not!
> >
> > On Wed, Sep 24, 2014 at 12:54 PM, Mark E. Scott Jr. <
> mscott@scott-usa.com>
> > wrote:
> >
> > > Apologies for this, I misread the mailing list text at
> > > http://cordova.apache.org/#mailing-list, didn't realize that this was
> > > for development of Cordova, not developing with Cordova.
> > >
> > > Mark
> > >
> > > -----Original Message-----
> > > From: Mark E. Scott Jr. [mailto:mscott@scott-usa.com]
> > > Sent: Wednesday, September 24, 2014 2:49 PM
> > > To: dev@cordova.apache.org
> > > Subject: Confused about Android API level and Cordova, does it support
> > > anything less than 19
> > >
> > > So,
> > >
> > > If I have android API 19 installed, everything works fine, I can
> > > execute the command "cordova platform add android".  However, to
> > > support the Galaxy S 3 devices we have for test, I need API level 17.
> > > According to the Cordova docs for 3.5.0<
> > > http://cordova.apache.org/docs/en/3.5.0/guide_platforms_android_index.
> > > md.html#Android%20Platform%20Guide>,
> > > it supports  API level 10 and later.
> > >
> > > Things still worked when I added API level 17, but we noticed it was
> > > still using the API level 19.  Upon removing API level 19, I get the
> > > following error executing "cordova platform add android".
> > >
> > > Error: Please install Android target 19 (the Android newest SDK). Make
> > > sure you have the latest Android tools installed as well. Run "android"
> > > from your command-line to install/update any missing SDKs or tools.
> > >     at
> > >
> >
> C:\Users\mscott\.cordova\lib\android\cordova\3.5.1\bin\lib\check_reqs.js:80:29
> > >     at _fulfilled
> > >
> >
> (C:\Users\mscott\.cordova\lib\android\cordova\3.5.1\bin\node_modules\q\q.js:798:54)
> > >     at self.promiseDispatch.done
> > >
> >
> (C:\Users\mscott\.cordova\lib\android\cordova\3.5.1\bin\node_modules\q\q.js:827:30)
> > >     at Promise.promise.promiseDispatch
> > >
> >
> (C:\Users\mscott\.cordova\lib\android\cordova\3.5.1\bin\node_modules\q\q.js:760:13)
> > >     at
> > >
> >
> C:\Users\mscott\.cordova\lib\android\cordova\3.5.1\bin\node_modules\q\q.js:574:44
> > >     at flush
> > >
> >
> (C:\Users\mscott\.cordova\lib\android\cordova\3.5.1\bin\node_modules\q\q.js:108:17)
> > >     at process._tickCallback (node.js:419:13)
> > > Error:
> C:\Users\mscott\.cordova\lib\android\cordova\3.5.1\bin\create.bat:
> > > Command failed with exit code 8
> > >     at ChildProcess.whenDone
> > >
> >
> (D:\projects\mobile\EMS-Mobile\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:135:23)
> > >     at ChildProcess.emit (events.js:98:17)
> > >     at maybeClose (child_process.js:756:16)
> > >     at Process.ChildProcess._handle.onexit (child_process.js:823:5)
> > >
> > > Does it, or does it not actually support earlier Android API levels?
> > > Do I have to move to an earlier version of Cordova to support API level
> > 17?
> > >
> > > I am using this in conjunction with phonegap, but was starting with
> > > the simple command of adding a platform.  I'm aware there is a
> > > preference for SDK level in the config.xml, but it didn't appear to
> > > have any affect on the cordova add platform command.
> > >
> > > I'm getting ready to add API 19 back in conjunction with the
> > > config.xml preferences in place, to see if it will compile with the
> > > right SDK tools in that scenario.
> > >
> > > Thanks!
> > >
> > > Mark E. Scott, Jr.
> > > mscott@scott-usa.com
> > >
> >
>



-- 
Carlos Santana
<csantana23@gmail.com>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message