cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Santana <csantan...@gmail.com>
Subject Re: Downloading the 3.5.1 cordova files for android when building the project
Date Thu, 18 Sep 2014 18:10:55 GMT
Don't be confuse by the version number of cordova.
In your case cordova command line interface (cordova-cli) with the command
 "cordova" is version 3.5.0-0.2.7
The android platform "files for cordova-android" is version 3.5.1 and yes
it's OK to have cordova cli at version 3.5.x-x.x.x and cordova-android 3.5.x

Check your PATH and that android and ant are setup correctly, and that you
can type "android sdk" and download Android API level 19.

If you did all this then open an issue with more info about
your environment at http://issues.cordova.io



On Thu, Sep 18, 2014 at 8:19 AM, naidu <pioneer.suri@gmail.com> wrote:

> I am developing an app using cordova 3.5.0 by using android-4.4.2 with an
> api level 19.
>
> It was working fine till morning but suddenly i am getting the following
> error,
>
> I know that the cordova 3.5.1 got released. I did not update my cordova
> version also and i have checked the version which is still 3.5.0-0.2.7.
>
>
>
> Can any body have any idea regarding this error?
>
>
>
>     D:\ClonedMobWorkspace\mobiledev>cordova platform add android
>
>     Creating android project...
>
>
>
>
>
> C:\Users\Admin\.cordova\lib\android\cordova\3.5.1\bin\node_modules\q\q.js:12
> 6
>
>                     throw e;
>
>                           ^
>
>     Error: Please install Android target 19 (the Android newest SDK). Make
> sure you have the latest Android tools installed as well. Run "android"
> from
> your command-line to install/update any missing SDKs or tools.
>
>     at
>
> C:\Users\Admin\.cordova\lib\android\cordova\3.5.1\bin\lib\check_reqs.js:80:2
> 9
>
>     at _fulfilled
>
> (C:\Users\Admin\.cordova\lib\android\cordova\3.5.1\bin\node_modules\q\q.js:7
> 98:54)
>
>     at self.promiseDispatch.done
>
> (C:\Users\Admin\.cordova\lib\android\cordova\3.5.1\bin\node_modules\q\q.js:8
> 27:30)
>
>     at Promise.promise.promiseDispatch
>
> (C:\Users\Admin\.cordova\lib\android\cordova\3.5.1\bin\node_modules\q\q.js:7
> 60:13)
>
>     at
>
> C:\Users\Admin\.cordova\lib\android\cordova\3.5.1\bin\node_modules\q\q.js:57
> 4:44
>
>     at flush
>
> (C:\Users\Admin\.cordova\lib\android\cordova\3.5.1\bin\node_modules\q\q.js:1
> 08:17)
>
>     at process._tickCallback (node.js:419:13)
>
>     Error:
> C:\Users\Admin\.cordova\lib\android\cordova\3.5.1\bin\create.bat:
> Command failed with exit code 8
>
>     at ChildProcess.whenDone
>
> (C:\Users\Admin\AppData\Roaming\npm\node_modules\cordova\node_modules\cordov
> a-lib\src\cordova\superspawn.js:135:23)
>
>     at ChildProcess.emit (events.js:98:17)
>
>     at maybeClose (child_process.js:755:16)
>
>     at Process.ChildProcess._handle.onexit (child_process.js:822:5)
>
>
>
> If you see error above somehow it is downloading 3.5.1 when adding the
> platform even my installed version is 3.5.0-0.2.7. I am not able to add the
> android platform even I have api level-19 tools.
>
>


-- 
Carlos Santana
<csantana23@gmail.com>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message